Download

Smoothing groups problem

Hello,

I have recently made a model, checked in engine (looked good) and sent it to a friend. The friend however, had the problem where he said the model isn’t looking smooth. I couldn’t repro the issue on my end. Gave the max file to him, he exported it by himself and then it looked good there, but when he sent me his own exported model that’s the same problem as he had, but now on my end.

http://www.xum.ir/images/2014/10/10/Untitled.jpg

Right: Modeled in 3Ds MAX, exported and imported in UE4. Smooth for me, hard for him.
Left: Sent MAX file to friend, he exported and imported in UE4. Smooth for him, hard for me.

I can’t answer this question really, anybody can help? :smiley:

Thanks in advance,
Alireza.

Hi Alireza,

This does seem odd.

When you and your friend are importing the mesh into UE4 what settings are you using and is your friend using the same settings?

Also, are you both importing into your modeling software and then re-exporting? If so, you will need to check that smoothing groups are being exported with the mesh as well.

Thanks,

Tim

Hello Tim,

I double checked and import options are proper and same on both machines. Export options from 3Ds MAX are also set according to UE4 docs. Never any kind of problems importing assets before. The only thing comes in my mind is it might be from switching to FBX plugin version 2013. I was always using v2014 and had no problems even though a pop up said it’s not supported.

Thank you for the time.

You have to figure out what is the difference between your machine and your friend’s.

I mean theoretically if you both have the exact same engine version, same version of fbx, same export/import settings and same .max file… I don’t see how this is possible, what else is there left to check? :stuck_out_tongue: