Smoothing Groups error importing from C4D, please your opinion

Hey guys,
Would like to hear some opinions please.

Is there a problem in ignoring the error No smoothing group information was found in this FBX scene ?
Considering the mesh looks nice and smooth anyway.
Note that, there is no solution for this, because I am using C4D R13, which does not have or write smoothing groups information in the FBX.

However the model is imported into UE4 just fine anyway, and looking smooth, except that the error message appears.

Apparently, UE4 generates smoothing groups when importing, or it is able to read some piece of information from the FBX.
But strangely, the error message is there anyway.

If I ignore it, would I have any problems ?

I wouldn’t worry much about this issue.
AFAIK the only way to import an fbx from C4D without this message is by using Cactus Dans CD tools fbx exporter instead of the internal one.

But in most cases the mesh looks just fine even with this warning.
Ofc. you should always check if there are any issues and eventually reimport or even change the mesh setup.

It has been a while since i used R13.
For me the fbx v6.1 (2010) in R17.055 always worked best, even imported textures and turned the U and V scaling of the material tag into a texcoord node.

Having more then one UV map can be a bit problematic in earlier versions then R16.
As soon as you have two UV Tags (with unique names assigned) the smoothing is lost no matter what you do.
Just a bug nothing that can be done except using R16 or later or maybe the exporter from cactus dan.

But back to the issue.
if you have problems importing the smoothing information, you should try to figure out good export/import settings.
For example:…016#post346016
also read #13

If everything else fails you can always manually edit the mesh to behave like you want.

A little context:
while in the 3D Programm smoothing groups, phong angles or hard edges are used to virtually define smoothing,
a realtime 3d application has not such a possibility.
Whenever there is a break in smoothing, the vertex points are split to get two independant vertex normals.
You can easily see this if you export a simple cube smoothed (phong > 90°) it will have 8 vertics, but if you export the same thing with flat shading (phong <90°) the vertexcount will be 24 (6 faces with 4 vertics).

Now with this knowledge, you can set the phong on any mesh to an angle of 180° but detach groups of polygons from each other.

Hi Kraid,

Thats what I was thinking too, despite the error message, I dont see any problem with the model and it looks smooth anyway and it even respects the values I set in the phong tag!
But I wanted to be sure, and hear someone else`s opinion too. Thank you very much for sharing your experience with this!

I never had any problems with double UVs though!

If someone still dealing with exporting skeletal meshes with joints to UE4 from C4D in FBX format.
For correct export you need to do few things.
1.Make sure Phong tag’s Angle limit and Use edge breaks checked as well as phong angle 180 degree.
2.Create normal tag via Shift+C on your mesh.
3.After exporting in UE4 go to Mesh-Asset Detail- select Normal import method and the at the top bar click Reimport Base Mesh.
Works fine for me.