Download

Smooth Sync: Sync your Transforms Smoothly across the network

Hey I have a very simple cube pawn with movement forward and backward using set actor location in tick based on input * speed. Anyway anytime i change direction from forward to back smoothsync stops syncing until i stop moving. This happens on both server and client (only tested in pie). Any idea what would cause this?

Using 4.25.4 and latest plugin.

@hard_code

You should only be setting position on the client that has authority over the object, or the server if no authority. It sounds like maybe you’re setting the position on the server or incorrectly in some other way and it’s overwriting the position that Smooth Sync is trying to set.

So I’m super new to this and I can get this to work. Sometimes.
UE Version 4.26.1
If I set up a blueprint and make the physics sphere the root. It works.
If I make a scene component the root, it doesn’t.
I’ve attached screenshots showing that info.

Replicates movement is off for both actors.
Component replicates is off for all sub components

LOL, never mind. I read the first page of the documentation… And learned the “Set Scene component to sync” Function

I’m having problems getting this to work, does anyone have a discord that I could join and help me out?

UPDATE: I figured it out, it only works if my mesh is the root of the Actor BP

Here you go @Cipher5 https://discord.gg/vtWvXa5

Thank You !

As a non-programmer, I absolutely ADORE SmoothSync and I’ll be using it religiously moving forward. However I’d like to request a feature, if I may. Would it be at all possible to have “add variable(+)” functionality added to the SmoothSync component?

I ask because I have a mountain of vars outside of SmoothSync that I replicate through the usual Unreal means, but two that are critical are very janky because of that, and I want to move them into SmoothSync so they’re, well, smooth. It’s just one extra rotator and a float.

then being able to pull a pin off of the smoothsync component node and choose “get/set (var)” would be SUUUUUUUUUUUUUUPER invaluable.

THANKS FOR READING! :smiley:

@fuestrine Did you ever manage to have a look at the ownership change issue that I mentioned a few months ago?

@fuestrine I have same problem as GuacFrog. I hope this will be solved soon. :slight_smile:

@Woondas Does your issue also involve physics handles? @GuacFrog Sorry nothing yet but I just upped the priority on that task.

Cool, I appreciate it. Let me know if you want a reproducible example

@GuacFrog Yeah, that would be really useful.

Hi, I was facing attachment problem like many others faced, I guess the solution is sent with the update but it still doesn’t work. My character teleports X0Y0Z0 location when I attach it to another actor (which is using SmoothSync either). I found out a solution posted on Discord and I saw the same line is still exist in the plugin itself.

What could be the problem?

Edit: Solved the problem, I was attaching character to the actor on character blueprint, it was happening on client side but the actor was on server side. I triggered the attachment function inside the server actor and it worked.

Hello everyone!
I have a problem. I use SmoothSync for my project. And when i use node SetActorLocation or Teleport. I notise a defect.
when using the plugin I need to move the actor using “set actor location” or “Teleport” via Run On Server -> Multicast, but there are problems that are visible in the video
link: https://youtu.be/Uybd8bg8amg
pls help me.
Thanks you

@amhad321 You should be using the teleport() method in SmoothSync. You only need to call it on the controlling client (or the server). You shouldn’t need your own RPCs, SmoothSync should handle it internally.

@**fuestrine Ok, **but how should I use it? There is no input or output in this method. How can I teleport an actor to coordinates 0 0 0?

@fuestrine, help me pls
im sad

@amhad321 Just set the position on the client like you normally would then call the teleport method. It uses the current position on the client so you don’t need to pass anything in.

Take a look at this video, and pay attention to the window that is located on the top left. An error related to the player’s teleport is clearly visible there. https://youtu.be/2orpLuDqJ7s
Thanks beforehand!