Download

Smooth Splines

Hi,

I am new to Unreal 4. I imported a height map from World Machine and built splines to form roads. I used the “Deform Landscape to Splines” tool to level road with landscape. But after deforming I see ugly artifacts or smoothing problems under the road spline. When I try to use the Flatten tool under Sculpt, the flattening applied to whole region, which results in uglier artifacts. I’m posting below:

Before:
4b50b3ead2a1eb742dd4c56ff06f40b041856e35.jpeg

After:
8cde8927a30722ebbe0a7151b1259336f23e683d.jpeg

So, what is the best way the smooth the artifacts under the road? Or why can’t I just smooth where I want?

Thanks!

I cant say for sure as i dont use landscape however typically when I make something like a road I make sure that there is some depth to is so that i can deform the area around the road (simlerish to what you have) to add more character rather then just flat terrain

That bumpy deformation might be because of not having enough vertices, a problem caused if you have modified landscape settings to not really popular values upon importing your height map.

I created the landscape according to the recommended settings:

Overall Size: 1009 x 1009
Quads / Section: 63
Sections / Component: 1
Component Size: 63 x 63
Total Components: 256 (16x16)

But, in order to get a landscape of around 4x4 km I scaled it by 400. Maybe the scale factor is the problem ?

Thanks!

It is from the scale factor. When I draw splines at landscape scale of 1 and deform the landscape, I get perfect results! When I scale the landscape with high values, the artifacts begin to appear. So if I create a landscape of 1009 and scale if by 4 I will get a landscape of around 4000x4000 cm or 40x40 meters. If I import my cars by scaling down them by 100, will it affect the vehicle physics?

Thanks!

You should be scaling the landscape at all.

  1. The unit for landscape is meters, so that’s 1009x1009 meters and if you scale it by 4 it’s 4x4 kilometers.
  2. Why are you creating a small 1009x1009 map and then scaling it up? If you want a 4x4 kilometers map, your height map should be 4033x4033.

But my vehicle models are around 400x200x200 in centimeters also the mesh viewer says like that. When I import them they will be too large for the landscape. So before importing the models what should be the size of them.

Also here what it says is different than yours:

Scale each vehicle to match the real life scale before you import them in engine. Currently it’s saying 4 meters x 2 meters x 2 meters. (If that’s right for that type of vehicle you have there, then the scale is already right and it’s the landscape that’s small instead).

From the link:

Edit: It also says in the link:

Is 1 vertex per 2 meters more than enough for you? then you should be happy how the landscape deformation to spline is looking bumpy.

Thank you for the help! I’m trying to sort things out…