Slow performance in UE4 Editor with (powerful) Windows 10 machine

I have just built a new Windows 10 machine with a GeForce RTX 2080 8GB, 32GB DDR4 3600MHz RAM and an AMD RYZEN 7 3700X 8-Core 3.6 GHz and I am noticing severe performance issues interacting with the UI in the UE4 editor.

My 4 year old PC was able to run the UE4 editor smoothly. But now I am noticing very stutterd/laggy responses when dragging blueprint nodes and mousing over menus (not just in the blueprint editor). It is very jarring. I can post a video of this if it would help but in general it seems to be having severe difficulty handling the UI.

I have noticed 0 issues with other applications (mostly games) that might indicate an issue with the computer hardware. I’m at a loss as to what might be causing this but it makes editing in UE4 an extremely tedious process. Any suggestions?

Edit:
I have made some interesting discoveries. I downloaded OBS to record my screen to show everyone the issue … . and the issue stopped happening. THE PROBLEM GOES AWAY WHILE OBS IS OPEN. I can’t explain this. It also made it difficult to capture the issue but I used my phone to take a couple videos.

This first video is from my phone, showing delays when mousing over menu elements. This is a brand new blank blueprint project. It’s not a laggy video, the stuttering you’re seeing is from the UI’s slow response. It’s not slow EVERYWHERE (blueprint nodes actually moved fine) but in 90% of this video you can see delays: 20200106 182612 1 - YouTube

This second video is from OBS. Same project, immediately after I finished the first video. Super fast and responsive! No issues! 2020 01 06 18 28 16 - YouTube

This third video is from my phone again. I first show the delay, then open OBS, press record and boom… problem goes away. I close OBS … problem is back. 20200106 183246 1 - YouTube

I can’t explain why this is happening… I hope someone else can. And please don’t give the solution of “Just record all the time!”

Edit 2: Just to try to get ahead of this, the problem is not that the editor is not being focused by Windows. Any time I show interaction with the editor I have clicked on it first to set the focus. I realize from the last video it looks like that could have been a possibility but … that’s not it.

I’ll be interested to follow up your findings, since I’m considering moving to Win10 some time in the future, no hurries :slight_smile: … Currently working fine with Win7 and literally half of your hardware specs.

  • Posting a video would be good.
  • Do you know if this happens when compiling shaders? Shader compling makes any PC laggy because use all your CPU cores.
  • Maybe silly, but try to ensure the Epic Games launches is closed… once happened to me that the launcher was doing some weird intense CPU consumption for not reason.

I should have clarified, my old PC was using Windows 10 as well and ran just fine. However, something was screwy with the windows update service and it hadn’t updated for over a year. So it’s possible a later Windows 10 update is to blame for this. I guess I would rather that than have something with my hardware not like UE4.

I will post a video in a couple hours. The issue happens all the time. Load up a new project and just mouse over some elements, the issue will be instantly apparent. Drag the screen around, drag some nodes, re-arrange tabs … it’s all slow and clunky. I’ll give it a shot with the launcher closed but I don’t expect to see a change …

Have you set a frame rate limit by any chance? That will also make BP editing run like a bad game…

Well… that’s incredible weird stuff happening there. And the chances of “fixing” it by using OBS is also amazing. I have no words others that give some random speculative ideas.

How the CPU usage looks when you are doing it with and without OBS recording. From the video looks like the performance is fine but the mouse input is the one lagging. Are you using any special pointing device… other than a mouse or mousepad?

Hard to know what the issue might be. I’m not familiar with your recording software.

Here are a few troubleshooting steps that I would take:

  1. Open Device Manager and update your drivers. Specifically Display Adapters, Monitors, Processors, etc. Anything that touches the UE.

  2. Open Task Manager and End Task on anything Adobe. Sorry to seem flippant here, but Adobe updates are very often the culprit, at least for me. End Task on anything not needed (Settings, Store, etc). This shouldn’t be necessary, but it might help. While the Task Manager is open, check your Performance stats.

  3. Check your monitor, monitor cable, etc.

No I have not

I have updated the original post with additional findings. Long story short: The problem goes away when I try to record it using OBS for some reason. I was able to capture it using my phone though.

  1. I did notice there was an nvidia driver update, new as of yesterday. I updated that (with no change) but nothing else needed attention.
  2. I have nothing from Adobe installed. It’s a fairly fresh install of Windows with a few games and UE4 installed. I did watch the Performance tab and noticed the GPU sits at ~20% usage when using UE4. When I start up OBS, GPU usage spikes to 100% and UE4 starts running fine. So it would seem that somehow my GPU isn’t running at a high enough capacity with UE4 alone and running OBS forces it to ramp up … I don’t know if that sentence even makes any sense.
  3. All seem fine from what I can tell.

I went into the NVidia control panel and looked to the 3d settings. For “Power Management Mode”, it was set to a low power mode (I forget the term it used). I changed it to “Adaptive” and instantly this fixed my editor.

It’s weird that this mode didn’t seem to negatively affect any other application but … as long as it works!