Slow character on low framerates

HI everyone.

I have a weird question. When I package my project, it plays fine on my computer, everything works normally. But if I drop the FPS, somehow the character is slow, and even his jumping are like if gravity was halved. I am getting quite desesperate

It is really weird, and I have no idea what I did wrong. Here is the project, if someone is brave enough to help me.

EDIT:: I tried to multiply the speed with delta time, did nothing, and jumping is still slow.

You gave a link to the game, not the project. There’s no way of telling what’s wrong from that.

For future reference, you can change the your framerate with the console command ‘t.maxfps 20’ ( for instance.

If your game plays differently at different framerates, then it will also vary across hardware.

Did I really upload the wrong folder? Wel now I feel dumb. Here, I updated it.

It DOES change depending on framerate. But how am I supposed to change that? WHen in multiplayer, my friend running next to me is slower than me because of that, it is kinda ridiculous

nevermind, jsut tested it, and found something interesting/

If I limit the framerate, the game is choppy (20 fps does that), but goes the normal speed.
But if I put enough foliage to drop my fps to 20,THEN it goes in a kind of slow-motion

Sounds like things are being controlled by tick rate rather than time in general.

That is indeed what I thought. Any suggestion to solve this? I am learning unreal by msyelf (Got accepted in a video game school, but too impatient to wait to learn), so I am kind of a noob

The way to correct frame rate changes is to use delta time. You multiply by delta seconds ( and another constant to get it back in the right area ).

This is what I tried, and it does not change anything. Did I do it wrong?

No, that’s it, you’ve got it. I have seen some stuff about slowness despite this, I’ll just try and find it…

( last comment )

This also goes into some good points… ( is it really different etc? )

I finally found it! I had to enable substepping and messing with framerate settings! Now it runs fine. Still, thank you for your help man!

Where is that set? :slight_smile:

In the Porject settings, Engine, Physics, and framerate section.

Then you also need to enable framerate smoothing, NOT fixed framerate

Cool :slight_smile: