Download

Skylight Radiosity!

Hi everybody , this is my first two weeks in learning unreal engine
i choose a very large scene to test unreal , i got pretty good result so far
i choose Preview for lighting quality and it took about 3 hours ( Ryzen 1800x )

and for final render i read article about modifying BaseLightmass :

NumShadowRays=32
NumPenumbraShadowRays=32
NumHemisphereSamples=256
NumIrradianceCalculationPhotons=2048

and lighting quality : Medium
and World setting :
static lighting level scale : 0.5
indirect lighting quality : 2.0
indirect lighting smothness : 0.8

but now after 48 hours sawm agent still calculating Skylight Radiosity

so if any body can tell me what to expect here Or is this wrong approach
and thanks in advance

Hi

I don’t know what version you’re using but since 4.17 there is no need to change/tweak the baselightmass.ini file!! Before we had multibounce skylight and portals it was necessary for nice results to get enough samples…
It would take AGES to calculate!!
I would stop the calculation, reset the ini file! Put portals in the openings/emissive surfaces.
If you want very detailed result you can go lower (0.1) with scale, 0.6 with smoothness and quality up to 8-10!! On a medium build you should get a very nice result with a LOT faster build time!
I think the rest is ok… you can tweak your end result nicely with postprocess!!

thanks Makigirl
i,m using 4.19 and already put light portal in windows
i’ll reset and give another shot
by the way should i use the last update of unreal every time ( now 4.20) or keep the version i start the project with , i read mixed opinions on the subject because for me as 3ds max user always wait for the first update of fix before install and the compatible plugins … etc .

What I usually do is check if there are any updates about lighting and if you want to use that option… if not there is no point of installing that version… IMO!!

I’d suggest avoiding upgrading the version for a project, unless Epic added something you need. It’s always worth checking the patch notes, for example 4.20 added Rectangular Area Lights and Cinematic Depth of Field.

If it’s a feature you don’t need to work around, like the depth of field, finish the project using the current version. And once it is finished, you can copy the project and try out the new feature in that copy.

The act of migrating can break things, and sometimes you might not notice anything until hours of work later.

NumHemisphereSamples=256 !
make it 32
this parameter has heavy impact on render time

If you are a user of Unreal Studio I would recommend to keep it up to date until the paid subscription will start, otherwise, it is useful to keep the version to the end of the project, the changes some time unexpected and hidden deep in settings.

As for your scene, What don’t you like about it? Maybe will be there is a sense in your case to set some object to movable and use Volumetric Lightmaps? It will save a render time.

hi guys
i just rested the BaseLightmass and add extra PC ( Ryzen 1800x * 2 ) to swarm and after another 48 it still stuck in the damn radiosity
and i have new problem unreal crash when i try to save as the level to make some test with night interior
by the way the folder size now about 50 giga ):

thank u **ZacD **very much now i understand how to think before update

i reset the BaseLightmass and i got the same problem

will sure i did only install unreal because of the studio , and i did not understand yet the difference between movable and static for render time or Volumetric Lightmaps

There is a lot of materials about Volumetric Lightmaps. The idea is, you bake a simpler scene without some of the small or flat elements and then set them as movable and they perceive the light from a Volumetric Lightmaps, not from they own lightmaps.

By the way what particuar don’t you like? Swarm agent also isn’t perfect on the picture just an example of its common flaw every core works independent and the result is defferent

Ok, remove the light portals (the more you have == longer baking times), use them only when you really need. For example when you have light splotches in dark areas with only indirect lightning that have windows.
Change your lightmass settings to this (check the picture) in medium quality and dont change anything in baselightmass.ini. Make sure that you have a limit to your lightmaps resolution to 2048px (which is too much anyway), if you need to go over this then you need to break the mesh to smaller parts.

And lastly I am not sure if this cpu is compatible with UE4, I would check inside the developer settings of swarm agent - “Local/Remote jobs default processor count” if it shows the count of your cores. The default values are 6 for local and 8 for remote, so if you have 16 cores so change those values to 16. Still I am not sure if this cpu is fully compatible with UE4.

Edit: I hope I dont sound patronizing but do you have Ligtmass importance volume in your scene?

I still think the reason is in the abundance of details. There is another approach as well for your walls you could try to make them one mesh. Though it will be hard I’m sure this will lead to better performance.

You could see here my test of such approach https://skfb.ly/6y9Lr

P.S. I’m pretty interested in this thread because I don’t have such a machine as yours and could not test Real-Time rendering for the saturated scene like this one.

I think it’s rather shading differences between modular pieces which can be solved with 0.1 level scale and 0.6 smoothness…

thank u guys for all the suggestion
i tried :
removing portal … same result

deleting skylight and install spot light on window ( as i saw in tutorial ) … same result

20180811_004346.jpg
i gave every test about 24 hour and unreal still stuck at radiosity
is there a way around this radiosity option or this is a must calculation

i am ok with that and i can render with one pc but i just want it to start render

well i did all of that and try it on other pc … same result
and i bought some scenes an tested them and they worked fine
and yes sure i have lighmass importance volume

i can give it a shot but the whole idea of me choosing very large scene is to test unreal capabilities for arch viz

It will be something else then… maybe your lightmap resolutions are too high… what resolutions you use (from small objects to walls)? Are you using HDRI for the skylight? How many bounces have you set for the skylight?

Just another idea… I had a very similar scene than yours! It took me I think 12-16 hours to build the lighting… There is an experimental GPU lightmass for 4.19 which gives a lot nicer results (imo) in like 10 times faster!!

  • mostly 512 - 1024 and 2048 for walls floor ceiling and for few big ornament
  • and yes i am using HDRI
    20180811_164426.jpg
  • and if u are talking about Luoshuang GPU i made some tests a week ago and yes it is fast not 10 times …about 2 - 3 for (me 1080 vs swam Ryzen 1800x * 2 ) but i got some shadow problems … for me CPU render was nicer … but i did not test it on this scene

Well I don’t know how many meshes you have in the scene… what is separate and what is not… but if you have thousands of objects and all of them has lightmap resolution between 512 and 2048: it’s a LOT!!
If this is not the case and you set the smaller objects accordingly… you’ll have to break up the meshes that have 2048 lightmap resolution: it’s faster to calculate more meshes with lower lightmap resolution than one mesh with a high one!
Just one idea if you haven’t tried yet: try to clean the cache in swarm agent!
…and I wouldn’t touch the indirect lighting intensity but leave it on the default: you’ll get enough radiosity with proper settings!

Yes that is the one! :wink: If it didn’t do the job for you then stick with the default CPU one! :wink:

just decrease Num Sky Lighting Bounces in World Settings

Once you built your lighting you can check how much time each asset took to build. There is a statistic feature in the editor: Build -> Lighting Info -> Lighting Static Mesh Info. Then in there use the drop down menu for more detail. You can also sort the columns.

Try rect light or want use skylight, set smootness 0,6