Skydome rendering anomaly on Android

For whatever reason it seems rendering a very simple skydome is generating some kind of emissive anomaly on my phone. It renders perfectly fine in the Editor, and in Mobile Preview (PIE), but on my Galaxy S6 it is showing up like this:


Here is the material blueprint:


I have all post-processing disabled, targeting ES2 Forward rendering with Android as a supported platform for the project.

Any ideas what is causing this? It covers the screen in a blocky yellow blob when any part of the ‘glowing dots’ are on-screen like it’s trying to do some kind of sun glare overlay post-process effect, but I have all of that disabled.

One thought I have is that perhaps because the material is taking in an Emissive Color, but that is required for an Unlit material as far as I know. I’m newer to UE4, so if there’s a better way to do this I’m all ears and eyes.

Try using WorldNormal instead of AboluteWorldPosition. In my experience, using AboluteWorldPosition as UV coordinates in mobile can cause unexpected results due to precision problems caused by the large values.

The yellow hue was caused by Mobile HDR being enabled; disabling that removed the post-processing glitch. I tried what you said *but there isn’t a **WorldNormal *node, only PixelNormalWS and it didn’t change anything. I do suspect there is some kind of precision issue going on, though.

Try turning on High Precision in the mobile settings in the material.

Tried that, no change.

Turns out this is a glitch caused by ASTC texture compression; building an Android APK with ECT2 compression instead fixes the problem. Not sure if it’s a limitation or bug for ASTC, but my problem is solved now.