Download

Sketchup datasmith re-import after upgrade to 4.23

Hi. I had a project with a model exported from Sketchup to Satasmith.
I just updated to 4.23 (from 4.22.1) and everything works except Datasmitch reimport.
It does simply nothing when I chose “Reimport”.
I can import again and everything works then, but I lost all the modification on textures. Reimport should keep everything.
It is known bug or feature? Is there any way how makes old modified model again synchronizable with datasmith file?
I updated also Sketchup export plugin to a version supporting 4.23.

Thanks for reporting, we found a regression with updated projects and Datasmith files in general. Importing in a new 4.23 project, reimport will work fine, but in an upgraded project it won’t. We are looking into it!

this issue also occurs when re-importing an asset in 4.22 as well. We’re currently trying to reimport a few static meshes but they’re just not coming in.

Thanks a lot. I tried to reopen my project in the older version, but it is already not possible, also when I did not save the project after opening it. Maybe would be great to automatically keep a backup of project file after conversion to the new version. And I, of course, I should do a backup of the whole project before migration to new version :wink:

When opening an existing project with a new engine version, the recommended/default option is to make and open a copy of your project:
convert1.jpg

The only way to not make a copy is to click on “More Options…” and choose “Convert in-place”, which we don’t recommend.

Very interesting. I definitely didn’t see it. Probably because I removed the older version of UE before I opened project. So it just asks me which version it should use. But I found backup in the backup folder and everything works again on old version.

It looks that have no issue on 4.22 with that. I did reimport many times already because I’m creating scene completly in the Sketchup and just render it in the UE.

It appears this issue also exist when exporting from 3D Max. I also can not reimport when using 4.23.

This is the error message I get in the log file when trying to reimport:

LogWindows: Failed to load ‘libalias_api.dll’ (GetLastError=126)
LogWindows: File ‘libalias_api.dll’ does not exist

thanks for clarifying this. logically reimporting in upgraded project should work, but again datasmith version conflict is also logical. new version means some improvements and new coding. so its better not to upgrade, for running project.

any news on this subject?

afaik that’s coming in 4.23.1

I tested 4.23.1 and it looks that its working!

In 4.23.1 it was working, but I’m not able to reimport on 4.24.0
I have a new export plugin for Sketchup. I enabled Datasmith import
When I run reimport, it ends with this error:
Could not find file “d:/Users/tomas/Documents/Obyvak.udatasmith” needed for reimport.
It always was on disk C:, I just installed engine 4.24.0 to disk D, but the project itself is still on C.
When I chose “Reimport with new file” it do exactly the same like “Reimport”. It doesn’t allow me to change a path.

Update: When I moved file to this location it reimport and also “Reimport with new file” magically started working.
But the result looks really very bad

It’s not working for me either in an upgraded project from 4.23 to 4.24. When I selected 'reimport with new file" no browser comes up. When I click the path link to browse to a new file path - nothing happens. Multiple restarts including system restart. Nothing works.

Maybe it’s to do with datasmith not being installed? I’m new to Unreal. I thought it was ‘included’ in 4.24, whereas in 4.23 it was a plugin. In any case when I try to install it as a plugin it says it’s already installed to all compatible versions. Very confusing.

In 4.24 it is directly part of Unreal Engine, so as a preinstalled plugin, but by default disabled, you need to enable it per project.
But anyway anything imported from an older version of UE is broken… completely new import into new project works.

Retested on 4.24.1 (including updated SketchUp exported plugin) and it works again!
Only one mesh was missing, but DataSmith -> Reset Overrides solved it.

Correct steps on how to upgrade:
1.) Open Unreal engine 4.24.1
2) Open project from the older version, it will suggest you create a copy of the project
3.) Enable plugin Datasmith Content and Datasmith (I’m not sure if both are really necessary)
4.) Restart Unreal Engine
5.) Now right click on DataSmith file and “reimport”. (only bad change is that DataSmith file now has no icon, it is just plain color)

Where di you enable Datasmith? I tried enabling it from the “Plugin” menu.

Yes, in plugin menu, but you need to have 4.24.1, in the older version it was as an external plugin.