Download

Skeleton Mesh from UE4 to Blender 2.8 and Back (no plugins)

After trying for more time than I would care for to get the standard skeleton to work on Blender and the bring it back I’ve finally found a way to make this work. It is terrible and cumbersome and I don’t understand why it doesn’t work straight out of the box but after reading dozens of forum posts I think nobody is sure of how to do this. This method does not use any plugins and is using Blender 2.8.

**Here are the steps:

  1. Export the Mannequin skeleton from UE4. Use the settings as so:**

​​
(https://wiki.unrealengine.com/Export…d_Re-importing)

**2) Open a new .blend file. Setup unit scale as 0.01. Delete everything.

  1. Import your Mannequin with these settings. This will be your “Rig Mannequin”. The most important option is “Automatic Bone Orientation”.**

**4) Un-parent the Mannequin mesh (Alt+P). You can delete that mesh.

  1. Go to each individual bone and deselect “Deform” from every IK/Root bone. You can also deselect it from the “_twist” bones if it is giving you any problems. If you forget this and just delete the vertex groups it won’t work.**

6) You can correct some bone position/roll on the Foot/Ball if you want to.

**7) Parent your mesh to the armature (CTRL+P - Automatic Weights). Refine the Weight Paint vertex groups if needed.

  1. After you are satisfied with the Weights. Un-parent the Mannequin mesh (Alt+P) and Keep Transform.

  2. Open a new .blend file (unit scale 0.01). Delete everything. Import again the UE4_Mannequin. This time DO NOT select “Automatic Bone Orientation”. This will be the “Export Mannequin”.**
    [ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_171217_1566326862472_972”}[/ATTACH]

**10) Copy the un-parented mesh from the first file to this one (do not copy the armature).

  1. Parent the mesh to the armature (Export Mannequin armature) with CTRL+P. Do NOT use any of the options to modify the weights.

  2. Use an “Armature” modifier and select the “Mannequin Armature”.

  3. Select the mesh + armature of the “Export Mannequin” and export FBX with these settings:**
    [ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_171219_1566326878625_488”}[/ATTACH]

14) Import to Unreal. Assign your current UE4_Mannequin skeleton. You probably don’t need to change any further options.

Does it have to be that complicated? Anybody’s got any other tips on how to do that in Blender 2.8 in a easier way?

Hi [USER=“710460”]Alex Mees[/USER] I’ve been working on getting a Blender UE4 workflow going myself and I’m not sure -X Y bone axes are correct. I am getting sounder results with X -Y as in the images below.

Can you please update this post with the import settings? The Unreal wiki is no longer online!
Thank you in advance, this helped me a lot even if it’s not complete

1 Like