Download

Skeleton from UE imported into Blender is TINY -- Why and how to fix? (pic)

Any help would be great. Thanks!
c3fa53c7f7756044a7924a56641457102a867968.jpeg

-How have you imported it?
-How have you exported it?
-You use the original SWAT soldier from maximo?

Because when I import it, it works perfectly :slight_smile:

Hi, Allen

UE use centimeters as units while blender by default use units which are more close to (should be treat as) meters (by default used unspecified units, but they are behave as an meters). Check your global scale settings for import, maybe you have wrong one. Also check the bound box dimension of whole skeleton after import and provide it here too, because you image is not much informative and you provide little information.

Hi Allen,
I used blender all the time for UE4 development and the scale thing can be fixed by either scaling the model up individually or by changing the global setting like Alexey mentioned in the previous post. If you are primarily using blender to build game content for UE4 then I would recommend that you change your global settings. In my case, I set blender up so that the default cube is now 100x100x100 rather than 2x2x2. A typical character is about 200 units tall and weapons are around 80-90 unit long.

I did noticed this problem the other day when I attempted to import the Hero-TTP skeleton model from UE4 to blender (i.e. blender to UE4 works fine as long as you do the above) so maybe that’s what you ran into. Keep in mind that blender’s .fbx routine just added support for importing .fbx models with skeletal meshes in 2.72 so it’s possible there’s a bug in their routine. I would find it interesting to see if you had the same problem with other character skeletal meshes. If ALL of them came in with the problems them I would lean toward thinking it’s a blender issue.

I went into UE4, right-clicked on the Mixamo SWAT Skeletal Mesh -> Export. Then I go into Blender and do “File -> Import” and select the FBX I just exported. I even tried adjusting my world settings to Metric and scale to 0.01 as I normally do. Then I scale the Mesh up 100. Those are the only settings I changed.

Could you give me your exact workflow? Thanks!

Yeah, I use meters scaled to 0.01. Do you know where I can find these global scale settings for import? Thanks for your help.

Allen, scale option I was talking about is the following (it is FBX import pane in Blender):

ff35720e82dade1ced1665f509c56e174a960935.png

But for your particular task I would recommend do the following:

  1. Start new Blender scene
  2. Clear it completely (remove any starting content)
  3. Setup global units settings and adjust corresponding viewport settings according to the instruction from here: Setup Blender units for UE (just do all steps exactly as described)
  4. Import your data using 1.0 global import scale (no scale)

It should provide you with the most accurate results (at least it is most accurate workflow I am myself aware about). Effectively, it will just prepare Blender to work with dimensions from UE and avoid any data conversions as much as possible. Hope it will help you.

<<<<<UPDATE#1
Just for clarification, I never do import from UE myself, so all information above is just my assumptions based on my current knowledge in this area (my team currently try to master the Blender-to-UE workflow)
>>>>>UPDATE#1

I use Blender and I’ve seen this as well. This is an issue with the way Blender handles bones vs. Unreal and has been a part of the system since UDK. It still works fine, it’s just a pain to work with. Remember that the only part of the bone that matters is the pivot, the rest of the bone is just there for reference. Model your character based on the mesh as opposed to the skeleton and select the bones in the outliner if it is that big a deal but changing anything about the skeleton will make it useless in UE4. You could also just model a character and use your own bones and try the new re-targeting system but I have never tried that. I find that the above problem isn’t really a problem at all.