SkeletalMesh Blueprint Invalid Data

I created a blueprint actor using the skeletalmesh class that will be use for my sequencer for more functions. but I keep getting “Invalid Data” error right after I created the blueprint. Am I missing references? Thank you


Hey @fma.scar!

On the bottom right of your screen when you see the error, there is an option to view the error log. Would you mind sharing that?

In the meantime, check this solved thread with the same error as you as it might have the fix you need:

Any additional information you can provide will be a big help in solving your problem!

1 Like

it’s included in the attached photo, the message log right? there’s no informations what exactly is the reason why it has invalid data. Please try to produce the process. just simply create a new blueprint and find select SkeletalMeshActor. then assign a character then compile. the error should appear.

regarding about the link, i don’t think we have similar problem. cause mine is a blueprint error. hopeful for your answer. thank you

Hey @fma.scar,

I’m not able to reproduce what is happening.

Was there a step you did in-between that was missed? Does this work for any other skeleton? Maybe redownloading your mannequin would help.

And the above thread does deal with blueprints as well, if that helps. One of the solutions involved reparenting the blueprint that was errored out.

I hope this points you in the right direction!

1 Like

I figured it out, thanks to your test and suggestions. I used a different SKM “Manny” and the error is gone.

Then tried to reapply my SK_Mannequin and my imported skeleted meshes but the error still persist . then I look all the differences.

My SK_Mannequin doesn’t have physics assets applied to it and it’s the one that causes the error. By default on my projects I don’t use physics assets so I delete them right away. so I created and assigned a physics assets and the error is gone.

Finally, all this time I though it was a bug lol. thank you for being patient with me :smile: