Skeletal mesh won't cast shadow?

There’s a model (the big girders thing) that I had to import as a skeletal mesh because it was too complex for static mesh importing, it won’t cast a shadow when I build lighting, no matter what.
I saw in the compile errors that skeletal meshes supposedly need a physics asset to light properly, which is strange, but even then, after I added a physics asset

Is there a trick to make skeletal meshes cast shadows properly? Should I just split it in several pieces to import as a static mesh? The latter option seems obvious but I hope there’s a quick smart fix for this problem because eventually I’ll have a big skeletal animated object that I’ll want to cast shadows, and that won’t be importable as a static mesh.

I don’t think you want to use a skeletal mesh where you actually want a static mesh. I think you should just try to get it to import as a static mesh.

I think you have the right idea: You need to import it as smaller chunks. It looks very modular with lots of repeating sections. Can you import just one chunk of it as a static mesh and then copy/paste a static mesh actor to form the whole structure? If those sections actually are different somehow, just leave everything in place in your 3D editor, and delete and export different pieces so they all have the same origin.

But now I’m confused. You said that you’ll eventually have a big skeletal animated object? So which one is it? Is this supposed to be a skeletal mesh? Or is it supposed to be a static mesh but you imported it as a skeletal mesh as a workaround?

I’m not talking about the same model, the thingy in the screenshot will remain static forever.
But I’ve also got some other stuff planned like a collapsing concrete structure, if that one also decides to not cast a shadow, then I don’t have the option of importing it as a static mesh, as it will need to be a rigged skeletal mesh to animate.

What shape physics asset is the model using?(something simple like a cube?)
If you are using a dominant directional light go to its properties and change the whole scene dynamic shadow radius to something like 2000 or even 4000 and see if the shadow will appear.

Yeah it’s something like a rectangle wrapped around it.
I’ll try the radius thing, thanks.

Sadly the radius thing didn’t work.
Why is lighting skeletal meshes such a pain, anyway?