Download

Skeletal mesh with crazy vertex from Blender

Hi guys,

I’m sorry to bother you with this, but you’re my last hope.
I’m exporting a skeletal mesh from Blender as usual, but there’s this crazy vertex that breaks everything.
The thing is when I only export the mesh, or even when exporting the whole and not checking skeletal mesh while importing in UE4, its fine.
I’ve tried removing he vertex, create another one and then build the faces again, I tried triangulation.
I’m stuck. I’ll never finish that Jam in time. =(

Thank you for your time though. =)

EDIT: It appeared fine when exporting from UE and then importing in Blender, but it was weird.
I also had a vertex in the wrong vertex group, but reassigning it to the right one did not work.
It seems the issue came from the fact the mesh wasn’t at the origin.
I’d like to know why though, as I did it on purpose so it would align with other meshes smoothly but I guess I’ll have to offset it by hand under UE4.

RE-EDIT: Nope, still have this crazy vertex. Slightly less obvious but still there.

LAST POST: I finally gave up and re-created the mesh…