Skeletal mesh scale wrong despite settings in order?

So, I made a custom rig for my project in UE4, I made sure to scale it to the correct size in centimeter in maya and use the z axis up, however, no matter what I do when importing the fbx to Unreal, it turns out very very tiny and laying in the ground instead of standing up. I’ve tried every tip on the internet available: setting the units to cm in the fbx exporter, trying to scale it in the importer of unreal, etc, and it simply doesn’t work, and I’m quite desperate by this point. Any solutions?