Download

Skeletal Mesh re-import from Blender breakes Animations

I tried to create cloth for my Skeltal Mesh with Blender 2.93.7 for Unreal 4.27, but run into the problem that the imported skeletal mesh is no more working with existing Animations of the Skeletal.

While searching YT for a solution I tried different import and export settings, and several plugins for blender, but none was solving this problem.

To describe what my expection is and what is not working i created a small project that describes what is happing. In the last picture you see that the skeletal mesh looks perfect, but if i assign existing animations they do not work.

My guess is that this has to be working if i want to assign the masterpose of the cloth to the bodymesh.

Of course i can retarget animations on a new imported skeletal, but that is not what i am looking for.

Is this maybe a bug or a missing feature?




Project Archive

I found the solution on a modding site. A PDF with 5 pages describes what to to for a older Blender version and works with the new blender as well. I described the steps for the new Blender below.

WaffleButters Abridged UE4 io Guide

Link found on Conan Exiles / Modding / Useful_links

The steps are:

  1. Export from UE as FBX 2014
  2. Import from Blender as FBX
  3. Clear and Keep Transfomrations
  4. Delete Group
    image
  5. Export FBX
  1. Import to UE4 on existing Skeleton

    Animation intact.

Sounds like a bunch of essentially useless steps:
http://mosthostla.com/gamedev/bonebreaker