Skeletal Mesh overlaping,

After setting set master pose my skeletal mesh overlaps my gear, anyway I can not render overlapping parts? or somehow morph the gear around the legs?

one method is setting up the armour on a separate skeleton, and copying the bone positions/rotations onto the other skeleton for the armour

I fixed this by decreasing the mesh scale to %.950