Skeletal mesh overlap collisions do not work with paper2D

Hello everyone

It appears that Skeletal mesh ‘overlap’ collisions do not work with paper2D. ‘Block all’ does work though.
Please set from within the “dragon blueprint” the meshes collisions to overlap As you can see they do not register.

Another thing that i do not know if it is a bug or not is this: Please press ~ and set collisions visible. Every time the mesh flips the collisions do not flip with it. Maybe i must do something to flip them as well but i am lost so any suggestions are more than welcome.

Thank you

Heya Roccinio,

Which version of the engine are you using for this? Thanks!

Hi Ben! Nice to talk to you again. The project i send you is from the official 4.8 but the same happens to 4.9 as well.

Hey Roccinio -

It looks like this is a result of using negative values when scaling a mesh. This is a known issue, UE-15682. I’ve added your information to the report and bumped up the community interest. There is however another way to achieve the same flipping action. Use a Set Relative Rotation Node with the Yaw -180 and the Yaw 0 and set your Material to Two-Sided. Using this method and your collision will be correct as the Paper2D sprite flips.

Thank You

Eric Ketchum

Hello Eric,

Thank you for your answer. I will go and try it out shortly. What about collisions not registering when overlap is enabled? Does the above workaround cures the collision problem as well?

Yes, sorry for the delay I wanted to go back and double check.

Eric

I am sorry if i am missing something but how did you manage to register overlap collisions? In this example if you press “c” it sets them to block and if you press “v” it sets them to overlap.

Hey Roccinio -

I am a little confused I am getting a registered Capsule collision when the collision is set to overlap on the project you sent me. What are the results that you are expecting, I think we are possible looking at different things?

Thank You -

Eric Ketchum

Hey Eric,

What you see is a registered collision only between the 2 capsule components (dragon and blue guy).

The capsule from the blue guy does not register collisions in overlap mode with the dragon mesh collision shapes (those capsule like shapes that follow the dragons movement).

But if you switch the dragon mesh collision shapes from overlap to block (c on your keyboard)you can see that it blocks the blue guys movement.

So my problem is that collisions between capsule components and skeletal meshes collisions only work in block mode and not in overlap mode!

Hi Roccinio,

I’m trying to help Eric out on this one, so please bear with me if I have misunderstood anything.

It looks like you are trying to get the players capsule to generate overlap events with the dragons skeletal mesh.

I got this working by enabling ‘Generate Overlap Events’ on the ‘Dragon’ component and the player capsule now generates overlaps and prints ‘MESH’. Is this what you are trying to do?

First of all i would like to thank both of you for stepping in and helping me out. Secondly i feel so embarrassed for not figuring this out but in my defense it is the first time since I’ve been using this engine that “generate overlap events is” not checked by default! I did not even consider looking twice mostly out of habit. Why when we import on a blueprint a skeletal mesh component the above is not checked?

Thanks yet again.

I believe a skeletal mesh doesn’t have this option enabled by default because most characters use their capsule to trigger overlap events. But it has the option for anyone wanting to do exactly what you are doing now.

Just a side note, a static mesh will have overlap events enabled by default because this is the expected behavior of all static meshes. Maybe that is what you are remembering that is set to enabled as default?