Skeletal Mesh not receiving light properly in shadowed areas

My skeletal mesh doesn’t receive light properly, I can be in a dark area and it doesnt have any shadows casted on it. What gives?


Make sure that your skeletal mesh has a physic asset :slight_smile:

Can you explain to me how a physic asset will fix the problem? I dont see how the two are connected in any way.

When you use the fps blueprint template, you will just have to enable “cast shadow” for the Mesh1P → in UDK you had to ceate a physic asset to get shadows (I thought that it will probably be the same in the UE4) :wink:

Per Object shadows used by Movable
components apply a shadowmap to the
object’s bounds, therefore the bounds
must be accurate. For Skeletal meshes
this means they should have a physics
asset. For particle systems, any fixed
bounding box must be large enough to
contain all particles.

, You’re correct that for any skeletal meshes you will need a physics asset for it to be shadowed.