Skeletal Mesh not displaying materials

I have a few skeletal meshes inside a Blueprint. Two of the meshes are absolutely fine but when I put the third in it’s having trouble. In the viewport it is displaying it’s materials correctly but when I preview in-game, it just has the default grey checker-board material.

I went ahead and added another skeletal mesh to my blueprint. Now the one that wasn’t displaying it’s assigned materials has been corrected but the new one has the issue where the materials just load the default UE4 checker pattern.

I don’t know if this helps anyone with ideas as to what is causing this issue? It was fine when I only had 2 meshes in the blueprint. For further clarification, it’s an animation using morphing/shape keys. Just a bunch of meshes morphing into one another like they’re transforming from one stage to the next.

Enable Used with Morph Targets in the material, or place the skeletal mesh in the level with the material assigned and it should compile automatically

That fixed the problem, thank you. :slight_smile: