Skeletal Mesh Import Error - Blender to UE4

Hey everyone,

I am still very new to the whole engine and in general still pretty new into game development. Today I created a model for a FPS arm. I did the following steps:

  1. MakeHuman (great software to create human and free), used that to make a human mesh (mainly focused on arms and hands).
  2. Exported the human and then imported him into Blender
  3. Within Blender I cut of the right arm and basically deleted everything but the arm.
  4. Centered the arm and then started rigging
  5. Created all bones as seen here →
  6. Connected the Armature to the mesh ready to export
  7. Exported the .fbx file into UE4
  8. After I hit ‘import’ the following Error messages showed up →

Although those were only warnings I thought maybe I can still proceed, however when I look at the Mesh and at the bones they look very weird within the engine. Here you can see that the Bones are not projected on the mesh like in Blender + some of the fingers are weirdly deformed →

So my question now is what could possibly be the error causing this and why cant it find some of the bones (as seen in the Error message/log)?

Any help is greatly appreciated, I already did some google searches, the main reason I found was that it could possibly be something that has to do with the scale of the armature and the mesh, but I did not really find a fix for that.

Thanks a lot everyone.
Kind Regards

By the way be sure to tell me if you need any more information, but I think the main points are given (hopefully) :smiley:

//EDIT1: One more Info, the .fbx file only contains a model and the skeletal mesh, no animations or anything else

//EDIT2: I tried using a hint from reddit to export it using FBX 6.4 (ASCII) however as you can see here → the bones are still a bit of, and the whole mesh is upside down. However no more error messages occurred, which is weird since the bones are still not correctly aligned.

//EDIT3: Sorry for making so many edits but I just found something new, I just looked at the Blender File again, an when looking closely I saw there is a dotted line there going from the start bone to the origin of the mesh, that might possibly stand for something but I dont know here you can see what line I mean →

So far found the following on Reddit gonna try a few things

I guess the line is from your armature. It handels the arm movement if you only move the hand.

Are you sure that you weighted all bones correctly? Would you mind showing me the weight of the finger bones that are deformed? Also we (me and the other HUB users) will need pictures of your export AND import settings.

Have you looked up how to import a skeletal mesh already?
This video is a bit old, but it might help you:

Also, what Blender Version are you using? Try to stick with 2.70. Everything higher caused some issues.


first of all thanks a lot! Although I did the “Automatic weight” option it still worked. So bascically I did what you said in your last sentence. I switched to Version 2.7.0 (before was on 2.73) and now it all works. I imported the mesh again, rigged the whole thing completely new and exported it, leaving all settings as they are. Imported that into Unreal Engine and 0 Errors + the Mesh is correctly visible and the bones are in place. Only the orientation was wrong, but thats no big issue. Here is it in the unreal engine →

Now dont leave yet I got one more question. As you can see in the Screenshot of the UE4 Bones there is that one Bone that is sticking out, I dont know where that one extra bone comes from because as seen here → there is no extra bone within blender. My Question where does that come from and how can I possibly remove that?

Other than that already THANKS SO MUCH, you already were great help can I somehow mark your comment as the correct answer?

Thanks a lot.
Kind Regards

I guess this bone goess is the one to your pivot root point. This point is normaly at (0,0,0) in blender, as long as you don’t move it. You can change it with some button combos, but better google them, because i don’t remember things like that pretty well.

But to sum this up, i guess you can ignore this thing. :smiley:

PS: I converted my comment into an answer. You can now accept it with the “Accept Mark” at the left side if you want.

Alright thanks a lot! :slight_smile: marked it as the answer, great help!