Download

Skeletal Mesh flipped towards the ground

Hey Folks!

I have been running into massive problem’s lately, but I kinda solved them, but that only spawned even more problem’s (though the following is more like a half-fixed problem I always get).

Long story short: I created a Skeletal Mesh and everything with it in MakeHuman, exported/imported it to Blender and from there I exported/imported it to UE4 (the reason behind this is that when I export a .fbx from MH I don’t have a root bone on my skeletal mesh, for what ever reason) and now 1) my character is flipped 90° toward’s the ground (face on ground) and secondly I retargeted the bones and I tried to use use “Ratarget Anim Assets” and it was deemed incompatible, I used the skeleton anyways, but the pose freaked out…

Here’s a photo of the skeletal mesh (btw in Blender the SM is perfectly standing feet on ground)

And here’s a screeny of the animation I tried to retarget (I rotated it 90° upwards manually btw)

I hope I don’t need to attach more thing’s. :smiley: Well, I will try fixing everything myself. If I have gotten it to work, I will reply to this thread immediately with the solution.

Well then, I hope you can help me, guys/girls! If you need more info’s, just tell in the replie’s, I will then reply ASAP. Till then, folks!
-Sakuie

Edit’s done: grammar issue’s solved (1)

I’m by no means a expert at animations and modeling but what I’ve seen here is what I think has to do with exporting model or the way its placed when exported.

It’s probably related to MakeHuman axis orientation, which is probably Yup.
UE4 works with Zup, that’s why you see the character rotated by 90°

Check if in MakeHuman there is an option to export with Zup and you should be good to go

[MENTION=2200]Enter Reality[/MENTION]

I tried to look this feature up in MH, but the option is only available when exporting as .dae, since I don’t use any program’s related to this extension, I looked it up in Blender, and yes it is available over there and I already exported it and imported everything into UE4, but the above problem still persist’s.

A neat thing to mention: before this post was created every single model was completely normal (except for the height of each model). I guess this is connected to my export setting’s in Blender (when I export with version “FBX 7.4 binary” my model is tall as ****, when using “FBX 6.1 ASCII” the height is normal, but it is flipped over, no matter if Zup oder Yup), and before ye ask: I already set up my display setting’s in Blender for UE4 and MH.

I just tried exporting a second SM from MH to Blender with the Rigify function, but 1) it didn’t to anything to fix my first issue and 2) it caused even more problem’s (missing bone’s, but it’s more likely that I used without proper setting’s).

Cheers.

Unfortunately I don’t have much experience with Blender or MakeHuman so I really don’t know how to solve this issue…
Worst case scenario, rent MayaLT for a month and fix all the issues there or try out something else, since I know that Blender still have issues ( :frowning: ) with UE4, especially on skeletal meshes

My suggestion is use UE4TOOLS for blender. I managed to get my model rigged and imported in less than 20 minutes. In the tutorial a makehuman model is rigged for UE4. I have tried it with my own custom model and it works.(problem came with the export as for some reason the plugin export didn’t work but the blender FBX export worked fine) I really recommend this plugin. It works wonders.

Just look below

If you export from MH as dae then use centimeter as measurement unit. In Blender set scene settings to metric and scaled 0.01. If you export from Blender (2.76b) then I would recommend Y forward and Z up and disable those anoying leaf bones. I would even recommend to rename the bones in Blender already to the UE4 names and even rename the armature (that orange human icon in the outliner) to “root” - or switch the rig and use the plugin from Lui as already posted.

If you would not use the plugin but use the MH skeleton without changing the skeleton instead then you have to modify the rest pose a bit (import a UE4 mannequin or use Luis Blender plugin to get a clue regarding the rest pose) and move a few bones to a pose that looks more like UE4 mannequin’s default pose (that means at least upperarms, lowerarms and some fingers). Afterwards apply the armature modifier (in object mode) to all mesh parts (so it does not change or rotate the mesh if you “remove” the skeleton). If it still rotates down 90° for some reason in Blender then apply rotation and scale in object mode first. If all armature modifiers (of all meshes - including hair and cloths, …) are applied then switch to pose mode and apply the current pose (that hopefully looks similar to the UE4 pose now) as rest pose to your skeleton. Finally add the armature back again as modifier to all mesh parts in object mode (so the mesh objects would follow the bones rotations again) in Blender. Export to UE4 (7.4 binary, Forward = Y Forward, Up: Z up, Smoothing = Face, Add leave bones = no). If you would export tangent space then make sure that you only use triangles or quads (there is a triangulate modifier) or you would get an error. If the import in UE4 looks good (if you do it right then you don’t get any error message from your Blender export in UE4) then open your mesh again and add a few twist bones to your mesh and split up the weights of upperarm, lowerarm, thigh and calf. This would improve the quality of your mesh if you would avoid that your hand and lowerarm bones does not twirl like a twisted balloon if you turn your hand upwards (for example if you use some “aim with a rifle” anim).

@Neutronux @slushpuppyZA

Thanks guys! I going to try everything out tonight and tomorrow! I am gonna reply again, after everything was tested!

Cheers.

@Neutronux @slushpuppyZA

I am sorry for my late reply, I was busy playing Tom Clancy’s: The Division and doing some training along the way. Anyways, gonna try it out this night (yes, I will! :D) and then gonna reply once more!

Cheers!

Something similar happened to me, but in Maya. I usually do this, and then click on Reimport asset. 4dfb4ce71dab5661d1c2e963167b21b5d1716d61.jpeg

Also, maybe your Up World Axis is not right. People usually forget to switch it inside Maya (I don’t know where it is in Blender. 0b8d36ae71ecf16d1212d2845473dcbc425a9589.jpeg

@Neutronux @slushpuppyZA

Ok, so far I was sticking on that project, of using the UE4 Addons Tool in Blender, butI miserably failed for now, since I saw many, many problem’s with weight painting, so I try to fix it by using other SM to transfer those weight paints and then I actually should, no doubt be fine! So far: thanks really! It helped me out, getting idea’s and maybe even solving stuff, if I wasn’t dumb enough to correctly execute. So, thanks! :slight_smile:
@Andrey J.

Well yeah, that seem’s to be the exact problem I kinda have, as I explained in a recent reply (“I guess this is connected to my export setting’s in Blender (when I export with version “FBX 7.4 binary” my model is tall as ****, when using “FBX 6.1 ASCII” the height is normal, but it is flipped over, no matter if Zup oder Yup), and before ye ask: I already set up my display setting’s in Blender for UE4 and MH.”), issue’s with that exact setting. But now that I have UE4 Addons Tool I guess it shouldn’t be problem no more. Still a thanks from my side! ^-^

So, I am going to do some training for my physique and go ahead and play some The Division, then in the evening I will be figuring out how to get my **** Human to work. Still: thanks everyone! Stay tuned for update’s! :smiley:

Cheers everyone!

You just need to follow a few simple rules, like scene scale in metric with 0.01 scale (then resize everything and apply transforms), also you shouldn’t have rotation transforms on the mesh in object mode, you need to apply object transforms.

Alright everone, this thread shall be closed now, since I am able to fix problem’s, thanks to everyone for helping out! I still have to figure out why Blender won’t let me assign the SM to my char, but that will be fixed soon anyways.

Cheers!