Download

Skeletal Mesh does not line up with the skeleton!?!!

Hi, so I exported a model with a biped control rig to fbx, imported to UE4, had only one warning about not being able to find the bind pose, but the real problem is the mesh doesn’t line up with the skeleton. Any animations I import the skel mesh will always play that anim offset. The animation plays well with no problems or any offsets in 3ds max.

Here is the pic:

Imgur

Thanks in advance.

Is this by any chance a Mixamo character converted to biped with their script? I ran into this with that workflow recently so i’m guessing it has something to do with bone conversion.

Yes it is! Used their script to convert to biped. But everything looks fine in 3ds max…

Good to know it’s not only me having this issue. :slight_smile: But unfortunately i don’t know how to fix it. I decided that the script isn’t perfect since you also run into strange bone rotation issues when you try to use a mocap animation on it. Head to Mixamo forums if you like and see if it is mentioned by anyone else. I havent checked there yet since i didnt need to fix this urgently.

Ok, thanks, I posted a question on the mixamo forums. I’ll post again if I have a fix.

Ok I havent got an answer on the mixamo forums yet, but I’ve been playing around a little and found that in 3ds max if you set the BodyPart channel to 0 in the Mesh Baker modifier it offsets the model just like it does in UE4. I’m assuming FBX doesnt export that modifier for some reason? Anyone know anything about that?

Here it is set to 100 :

And here set to 0:

Good catch!

Found a way to fix it…select that modifier > right click > Collapse To. Do this for every mesh and dont touch the Skin modifier. Export again and bones should be located properly now. I don’t know if it causes any issues later on though.

Ah ye I tried that when I found it, but when I collapse the mesh baker it seems to disconnect the rig from the mesh.

Hmm, that’s strange. I just tried both with the character in T pose and with animation applied, and it didn’t get messed up like that. You are collapsing only the mesh baker, correct?

The way I did it was open the T-pose file, collapse the Mesh Baker and it seems to work, but when I import an animation (update the T-pose animation) that’s when the rig disconnects for some reason.

Tried that too and still got the same result. :\ Upload the file somewhere if you want me to take a look.

Ohh I see what’s happening, when I try to import an animation which has the mesh baker modifier it won’t work. But if I go into each animation file and manually collapse the Mesh Baker then I can import and everything works. I will import into UE4 see if everything works as it should.

YESS! All works as expected in UE4 so far. Guess that the way to fix this issue for now!

Awesome! Thanks for figuring this out. Saved me some trouble in the future. :stuck_out_tongue:

Hi

Iv been trying this software for about an hour as i had issues importing meshes into unreal, seems to work fine importing but im scared its gonna make me lazy and less skilled as it does everything for u. Do you guys pay for the service? it seems very expensive.

thanks

You wouldn’t want to use Fuse if you want a very specific and unique character for your game anyway. Mixamo’s Autorigger is pretty awesome though, and there is no shame in using something that makes rigging easier.

i agree its brilliant, but do u pay for it everytime u want something rigged?

No. There was a polygon limit for the poly of the character you want rigged when it first came out, i dont know if it still exists. And once i heard there is a limit to the number of characters you can get rigged for free every week but i havent tested it.

ok, trying to pm u jackie but ur mail is full