Download

Single Line Trace somtimes goes through landscape

Hey,
I’m trying to get the location where the trace hit the landscape.

73332237a02e2b50731b355887a5df8c916347e4.png

Unfortunately on some locations, the trace doesnt hit the landscape and is just going through it.
The camera is below the landscape, that’s why it seems to be invisible in the image below.

http://s14.directupload.net/images/141116/3yy2pdto.png

It just happens on some locations, mostly it works. It’s not random, if it works once it always works, and if it’s going trough on some location, it always does.
The Landscape is the only object which is blocking the Terrain Trace Channel.

I really would like to know whether this is a bug or I am doing anything wrong?

No idea? I really would like to continue, but this “bug” doesn’t let me…

trace complex?

I already tried this, it doesn’t make any difference. :frowning:

Are you sure that those traces dont hit? have you counted the “misses”? maybe its a display bug

I’m absolutely sure they don’t hit. The problem is that every of these traces which is going through is returning the location (0,0,0). And I really notice that in game. Objects which should spawn at the location are jumping between the real position and (0,0,0).

could you give me some more input on the whole thing? you can also pm me if you want.

What exactly is “more input”? This is the whole Blueprint Function:

The landscape the trace should hit is just a flat landscape.

Have you tried to change the collision thickness? to like 32 or so

yes, I tried that, doesn’t change anything. :frowning:

Hello,
couldn’t it be the collision of your mesh which has a trouble? If for some reason you have some holes due to a glitch on update or something ? Only an idea to help…

I deleted the whole landscape and created a new one, same problem :frowning:

:frowning: Have you try if you have the same issue with basic line traces ?

What is a “basic line trace”?

Sorry, i meant trace channel (visibilty / camera) when other meshes don’t block for example.

I have tried different trace channel, all the same problem.

honestly, if your line trace seems ok and your mesh seems ok, it looks like a glitch / bug / thing not cool and if i was in your situation i would now open a thread in answerhub and ask for an epic staff member opinion.

Last thing i would try before answerhub : Have you the same issue in a new project ? If yes, you may need a verify of your engine. If no then your project has a trouble and you’d better migrate.

I already opened a thread in the answerhub 3 days ago: https://answers.unrealengine.com/questions/133871/single-line-trace-does-not-always-hit-the-object-l.html
Haven’t received any answer yet :frowning:

I also created a new project which just contains a landscape and is tracing the mouse, there I have the same problem. And I verified the Engine, but still same problem.

If it would be a bug, wouldn’t more people complain about this? I guess doing a trace on a landscape is nothing really special…

I totally agree that if it was a common bug it would have been reported.
If things in ue4 are fine with all except this and engine seems ok, it may comes from the mesh creation / import wich seems good but is not (something like uv / height map / other setting)

I am really sad for you because this is a really paralyzing trouble.

I don’t import any mesh, I just create a new flat landscape within UE4. Everybody can try this out within 2 minutes. Create a new project, create a new landscape, trace from the mouse position through the landscape. That’s all. :frowning: