Single Layer Water Shading Feedback

Tried it in preview and can say that is good to finally have ability to render water in stock unreal engine.

Few thoughts/suggestions:

  1. Ability to override vertex normal for pixel normal offset refraction mode. This refraction mode relies on vertex normals, which large body water meshes commonly do not have. Without said feature, water shading model cannot be used with screen-space projected grid and several other projections.

  2. Velocity output, including tessellation, working with previous frame switch. A bit on the luxury side of things, but still quite needed.

  3. Planar SSR.

What does exactly the single layer water shading model? Why does it do that the current shading models cant?

Seconding this! I can’t find any information on the new shading model anywhere, and I’d be curious to know how to better use it (currently I’m just testing a whole range of parameters).

One thing I’ve noticed is that it seems to do refraction correct depth fading. With a standard translucent material, the refracted color and depth used in the standard DepthFade node don’t match up. When using this, setting absorption (it has to be fairly low, 0.001 seems to be a good starting point) changes the depth fade distance.

However, opacity doesn’t appear to affect the actual opacity of the material, but some of the absorption, scattering, and lighting.

Dropping by to mention, that lack of optional depth pre-pass is significant inconvenience of water rendering system, which makes it overall appreciably slower, than simple forward+pre-pass for more or less high end materials.

I’m not sure what the default set-up for this shader should be. Also I’m guessing this is only meant for large bodies of water (ocean/lake)? Looking at it on a small area indoors I see a very icky graininess on the the surface.

Oh never-mind!…er#post1789028

It works equally well for any body of water.
Noise is SSR. It can be disabled with a cvar r.Water.SingleLayer.SSR

Looks like single layer water shader still doesn’t support planar reflections. Is it supposed to stay like that?