Download

Single Digit FPS in Editor, yet not taxing the system nearly at all?

I have a problem with UnrealEd 4. It seems as though I’m only using 50% of my GPU and only 12-13% of my CPU, and the GPU isn’t even using its full clock (it’s in)!

I have tested numerous games, which work completely fine (Sonic Generations, Sonic Lost World, Crysis 1 and 2, Counter Strike: Source, Batman: Arkham Asylum, Duke Nukem Forever, Unreal Tournament 1999), all running at over 100fps, but for whatever reason, my OS doesn’t think that it should put any effort into UE4. Sometimes I get decent framerates (60fps+) if I switch between windows, or leave it alone, but if I start or end a simulation, it drops right back down.

There’s nothing intensive going on in my project. I’ve got some bare-minimum stuff here.

Specs:
Intel Xeon X5660 6-core at 4.2ghz
32GB DDR3-1600
GTX 760 4GB Edition
250GB SSD (Windows 7/Unreal Engine 4 Directory)
2TB HDD

There’s absolutely no reason why this should be happening? What should I do?

What happens in an empty / blank project?

Everything is completely fine. Hmm, any suggestions as to what switch I might have flipped in my project?

Like I said, if I go to test my project, or edit it, in the viewport, the framerate will eventually level out and hover at 60, but if I go to another screen, or window, or even another tab in the editor, it’ll drop to 4fps. Especially if I mess with blueprints.

EDIT: I may have solved it, I turned off Enable Metal/Vulkan/High-end mobile Preview Rendering in editor. Don’t know why that was on in the first place, but things seem okay for now, I’ll update again if not.