Since updating to 4.10.2, project fails to load

'The following modules are missing or built with a different engine version:


Would you like to rebuild them now?’

‘Landscapetut could not be compiled. Try rebuilding from source manually.’

I have not even the slightest clue what is going on.

Did you build your UE4 environment from Github source???

I wouldn’t even know how to do that.

Good point… Sorry… I’ve seen that error when building from Github. Never seen on regular editor, sorry…

If it is a C++ project the error means your classes are failing to compile due to coding errors (some classes and function calls change when the engine gets updated). You should get into your code and check what should be change so you can compile it for 4.10. Also 4.10 requieres the latest version of Visual , so that might be causing the problem too.

Check this forum thread:

If you were already on 4.10 this might be a content error. Try creating a new project and add your code to it. if it compiles, start moving your content to it on small bulks to try and narrow down the possible problem.

Hi Clol7,

First, check to make sure you have VS 2015 or the Redist installed on your computer, as Bariudol points out, it is necessary to run 4.10 and above. If this is not the error you are experiencing, try running a verify on your engine build. You can do this by going to your Launcher>Library>Engine version dropdown menu>Verify. This will check to see if any files have been damaged or are missing and repair or replace them as appropriate. If this does not work and the suggestions from other developers here does not work, please let me know and we can continue trying to resolve this error.

I had it on a trial license, it has since expired.

Now that I think about it, that might be the problem, I had a few C++ classes in the project, nothing was in them, but again, expired trial.

That makes no sense, I updated via launcher just fine, even though the trial license expired ages ago. Not to mention that this is the ONLY project that fails with this.

You can use the express version that is free.

Well, I apparently already had the Community version, which is also free. Apparently getting that online was merely the formality of signing in.

However there was still no such luck with the project. I’m verifying at the moment.

So, I solved it, I was missing Common Tools for VS 2015. Good thing the setup program lets you configure stuff like that without needing a reinstall.