Since update, project crashes on launch

Hello there !

Since I updated my Unreal Engine to 4.1.1, I can’t launch project I’m working on. My other projects are still working fine. Can you help me get it working again ? I included dump & log.
project I’m working on is only BP.

Thanks :slight_smile:

link text

No idea ? I lost a lot of work, and I can’t figure out how to restore my blueprint inside another project.

Hey vychnou,

Can you start a new project and move BP .uasset into its folder? If you do that, does it still crash? If so, please attach the .uasset and we can take a look at it. Thanks!

Thanks ,
I tried that, new project crashes when I copy/paste my main blueprint. It seems to be corrupted.
Is there a way to fix that ?

Would you mind attaching corrupted BP file?

[link text][1]
Sure, here you go. I’d really’d like to know how I can fix file and thought process behind it, I don’t want that to happen in a further development step.

Thanks in advance
[1]: 6744-brick. (83.3 KB)

I replied in wrong location, sorry :confused:
Please see below

Hey vychnou,

Thanks for providing that information for us. I was able to reproduce issue on our end, and have entered a bug report for our developers to take a look at. They may be able to recover Blueprint that’s causing problem, but there’s no way to be certain. I will let you know if I get any updates for that.

Out of curiosity, if you run project in 4.0.2, do you still get crash? If not, you should be able to open it up, copy nodes, and paste them into Notepad, then from there paste into a new Blueprint in a 4.1.1 project without a problem… I would of course attempt this on a new project rather than one you’ve spent any time on.


Hello ,

Thanks for your answer. I spent a couple hours re-writting most of blueprint so it’s ok now.
I’ll try to run project in 4.0.2 to see if I can succesfully open blueprint.

Please keep me informed, I’d like to know why this happened and how can I prevent this (or at least successfully recover from it).

Kind Regards,