Simulated Physics stops in mid air after a few seconds UE4.14

Hello community,

I just updated my project from UE4.13.2 and for some reason, an actor I had stopped behaving correctly. I have a BP Actor containing a destructible mesh with Simulated Physics enabled and a ProjectileMovement and RotatingMovement components as well. When the actor is launched up and is rotating, it stops in mid air as if Simulated Physics on the destructible mesh is turned off. The Blueprint has not been changed since the previous version of UE so I’m at a loss as to why that is happening. I’ve tried turning on random checkbox (force sub stepping, auto-activate, etc) but this seems like a bug. Any clues?
Thank you.

Ok after deleting the ProjectileMovement and RotatingMovement Components, the issue was still there. I found a setting for “SleepFamily” (under the simulate physics’ more options section) on the destructible mesh itself. And found that since the actor was moving slow, the simulation was falling asleep under “normal” thresholds. By setting the family to “sensitive” (custom is also an option) it did not fall asleep as it reached it’s highest point.

Thanks for this. It was driving me nuts :slight_smile: