Simulate Physics

Is it possible to simulate physics when the root is not the static/skeletal mesh?

I have a BP_MasterPickupItem that does not have a mesh assigned. I have created two different childrenMasterItems from that, one with a static mesh the other with a skeletal. I am not able to simulate physics if the root is not the mesh. Is there a way around this? I have tried doing this in the construction script of the childMasterItem setting simulate physics on the mesh but it does not work. What am I missing here? Is it even possible to do so if the root is not the mesh? I know the mesh has to have collision enabled for physics to work, thats not the issue.

Any advise would be lovely!


Yeah you should be able to fine, have you made sure that all of your actors are set to moveable and not static?

Omg… haha. No. How silly. This is more than likely the issue… will report back if this is the case.

Thank you!

It is but you wont be able to move :slight_smile:

If you jump tho you will still fall. and do it on the capsule component.

Do something so you can disable it in the blueprint agian :slight_smile:

So, doing some testing… The root is set to “Movable” you do not have that option for any of the children components. Instead of setting “Simulate Physics” on the BP_MasterItem I have to do it on the child that contains the actual assigned mesh/static mesh. Now what I have found, is that my trigger collision (for picking up the actor) does move with the mesh. This is probably because I need to have the collision sphere to be the child of the mesh…?

Doing some testing I have found that both the mesh and the collision sphere have an option for “Simulate Physics”… Do I need to enable it on both?
What should be my setup?

Currently, I have a mesh that has a collision sphere that is used as a trigger for adding a widget to viewport and enabling the ability to pick the actor up. If a force moves the mesh, the pickup collision sphere stays put.