Download

Simulate physics, objects move without being touched.

Hoping that someone can tell me how to keep all these objects from jumping off the table when I hit play, while maintaining the physics when the eagle runs into them. If you can, I will love you forever. :slight_smile:

Proper collisions.

Hey, that’s a really awesome answer, did you spend all day working on that? I know I’ll spend all of this one trying to figure out how that answer will help me! :slight_smile:

Everything is currently a physics actor. I would think that for physics actors things shouldn’t just jump off table as soon as you hit play, objects at rest, something something. I’ve tried, at least I think, pretty much every combination of Physics actor, worlddynamic, etc. And I always get either the same or worse results. I’ve tried the presets and as well setting them all to custom, and the things that should be blocking the other things appear to be setup correctly.

One thing that is odd is that any of these meshes that I want to move, you can’t apply either a simple or complex collision in the mesh editor. They’ll apply in the editor, but won’t save. One in particular also won’t let you do simple at all, ie you can only select complex in the editor, but that isn’t saved either. Well, I should say you can select it, and the check mark appears, but no collision box appears around the object for simple collisions. There are two objects where this happens, and you can’t ‘simulate physics’ on either of these two objects. Edit- no collision primitives in the mesh is probably the reason for this.

I realized later you might be saying UE doesn’t do proper collisions? Or are you saying that I need to do something like turn on physics after a hit event or something along those lines?

Thanks!

No. I’m saying you need proper collision.
the objects are probably setup as approximations or spheres. You need to change their collision - for a video, probably just go with complex collision and call it a day.