Download

'Simulate physics' not working on a physics asset

I am trying to move a character with physics and applying force to boost it up, but am told that I cannot apply force or torque to my object unless ‘simulate physics’ is on. I do have simulate physics on in the skeletal mesh within the BP. At this point, the physics asset on the model itself are moving, however the character is not reacting to gravity, or able to see the force being applied to it, so it just sits in limbo.

I have also tried changing the collision types to the various custom types.

I have also tried changing my root bone in my physics asset to be kinetic, which causes my Actor to respond to gravity, but then loses its physics asset wiggly-ness. I get an error: “Attempting to move a fully simulated skeletal mesh SkeletalMesh. Please use the Teleport flag”.

If anyone has any idea on what I might be missing, I would love to get my physics asset up and running and responding to physics! :slight_smile:

I figured out a solution, by parenting my physics asset to a collision cube, and using the collision cube as the physics that is affects by gravity, and set up the physics asset to only worry about dealing with the jiggly physics. I’m not sure if there is a way to apply physics to a physics asset, and have it respond to gravity without parenting it to another object, but this is working for me now!