Download

Simulate physics is disabled when restarting the engine

Hi,

I have a project on unreal engine 4.14 for VR and I have a rock that is pickable and throwable. All works great but now I want to add it an additional collider to put an special event when it is overlaped. I test it and it works as I want.

Then I close the engine and open it again, and the surprise is that the rock has the “Simulate physics” disabled (it was enabled before closing). If I enable it again, the rotation of the rock when I grab it in-game is weird, doesn’t do what I want.

Also, when opening the project there is no error or warning message that I can follow to find the cause.

Any idea of why is this happening or how to find it?

Thanks in advance.

make sure you are editing the assets and not the in game instance settings. So go into the mesh and properly set up the collision settings, then go into the blueprint and edit the physics. You can also set collision enabled in the blueprint event graph. What will make it reset or glitch is messing with the instance physics settings by clicking on the asset in the world outliner (or game window) and editing the values from the details pane. Make sure you are properly saving before closing as well.

I recommend using event hit instead of overlap for physics objects. I think overlap is more used for triggers and static assets, any moving assets (which my game uses thousands of) are all optimally calculated with event hit. These types of interactions are very complex so you should test the package build to make sure it works (sometimes messing with physics and collision can cause errors in the packaging process that are not apparent when testing in the UE4 editor so it’s good to test build every few days as opposed to working on your stuff for a few weeks and realizing you have thousands of errors and have to start over).