Simply cannot launch to android with UE5.0 no matter what - error included

So I have been struggling for days to find any information whatsoever on how to create a location based AR game on UE5, but to no avail. There is almost nothing anywhere that helps. I’ve managed to figure out how to do it with what’s available and using the handheld AR template as a base, but I can’t even launch it to my device as it keeps saying this:

“UATHelper: Verifying SDK and Device (Android): Running AutomationTool…
UATHelper: Verifying SDK and Device (Android): It was not possible to find any compatible framework version
UATHelper: Verifying SDK and Device (Android): The framework ‘Microsoft.WindowsDesktop.App’, version ‘3.1.0’ (x86) was not found.
UATHelper: Verifying SDK and Device (Android): - The following frameworks were found:
UATHelper: Verifying SDK and Device (Android): 6.0.4 at [C:\Program Files (x86)\dotnet\shared\Microsoft.WindowsDesktop.App]
UATHelper: Verifying SDK and Device (Android): You can resolve the problem by installing the specified framework and/or SDK.
UATHelper: Verifying SDK and Device (Android): The specified framework can be found at:
UATHelper: Verifying SDK and Device (Android): - Download .NET Core 3.1 Runtime
UATHelper: Verifying SDK and Device (Android): BUILD FAILED”

I’ve tried everything - installed 3.1.0 (x86) and even tried moving it to the same folder as 6.0 and having them both there, but then deleting 6.0 etc. Nothing I do will get UE5 to locate .nt 3.1 and therefore it just continuously refuses to verify. I can run it anyway but nothing happens.

Also, whenever I press play it says that there is an AR plugin missing or unconfigured but there is nothing in any of the documentation about which one to install so I am lost with that.

And I can’t remember where now but it keeps saying the android SDK wasn’t installed properly either, but it was, many times, following the instructions in the UE docs to the letter until I knew exactly what I was doing.

It’s a real shame because I was really excited about using UE5 and after a very long time deciding between UE5 and Unity, I chose UE5. But, unfortunately, given that I can’t even use the demo, I am afraid I am done. I’m off to Unity. Not that anyone will see this, let alone anyone from Epic. What a waste of an entire week when I’m on a deadline too. Your documentation for even just getting started is wrong and needs to be updated, I mean it literally says on it all “not for UE5” even when the dropdown has 5.0 as an option. How can you release a new version, but not update the tutorials on how to use it!? That makes no sense…