Simple Sketchup model, light leaks. Can't resolve.

I made this very simple SU model and exported as a fbx and imported to UE4. UE4 generated what look to be clean lightmaps, I’m no expert though. Anyhow, I set the map resolution to different settings and it still has a problem.

I do Archviz for a living and was hoping to have a workflow of SU to Blender to UE4 but that’s a no go as something happens to the SU model in Blender when it exports as a .fbx that UE4 says that it has no triangles which isn’t true. So, I tried SU export as .fbx to UE4 and get this. I can’t use software that is hit and miss in combination with each other so if I can’t get a work flow working with these two options I’ll have to look into building models in Blender which I really don’t want to do as SU is my preferred modeler for building shells.

Anyhow, any advice appreciated.


have you built lighting?
what is the resolution of your meshes?
does your walls have thickness?

Yes, I built the lighting, the walls are 6" think - I extrude up from plan view. On the uv’s for the lightmaps that were auto generated I tried up to 1024. I also tried over lapping in SU the walls to the floor which is also 6" thick.

It’s odd because the first scene I did worked but his one doesn’t.

This is what the auto generated lightmap looks like.


Even after building the lighting I get the preview text showing still, that isn’t right is it?

one lightmap for the whole piece isn’t enough for good quality imo. break it up and unwrap each wall individually. same for the floor and ceilling. sorry for grammar im on a tablet.

Hi ri3dviz, I don’t know the reason of the “preview” text even after building light, but as for the light artifacts on the right wall and in some part of the floor it should due to the bad placing of the UV into the lightmap; I think that it’s better make a simple planar mapping inside Blender than an auto generated UV inside Unreal, because the Blender one can be adjusted if needed the other not

Thanks for the replies guys.

Something doesn’t make sense to me. I followed the instructions in this thread, see post 7. He seems to be getting good results straight from SU. As I mentioned SU to Blender to FBX does not work as UE4 gives a no triangle error so unless I use Blender to build my models which I don’t want to do I need to resolve SU to UE4 or look for another software to do animations with.

I’m not sure with the projects I get I can spend the time to UV map each and every surface in the SU model individually, it may be too much labor for the fees I get. Anyhow, I’ll try once more today with a new SU model and see.

From what I understand, meshes made in Sketchup can have issues.

But, it looks like the issue is that the floor may extend beyond the walls–if it’s visible outside of the wall then that part that’s visible will receive light and the pixels may bleed to the interior. When doing an interior, make sure that walls/ceilings/floors don’t extend beyond each other. Also, it can help to make walls have thickness, so you would have an outside surface and an inside surface and that can help as well.

Yeah, I tried many ways still had problems, I always model with a wall thickness, mullions etc.

I’m pretty sure the problem is the single huge lightmap for the whole room…Even with a res of 1024 it should not be enough I think. I’d personally use a 1024 lightmap for each individual walls, floor and ceiling.

My guess is: the leaks are due to overlapping geometry.

  • In your auto generated lightmap, I don’t recognize the shape of the floor (doors, windows should be ‘sticking out’ of the floor plane -> walls are cuts in the floorplane)
  • For more easy debugging & fine tuning I would always split the objects per logical element and apply a unique texture to it: walls, floor, ceiling. By doing so you can also tweak the individual lightmap resolution for each element. The floor and walls will most likely get a higher resolution than the ceiling.

Also see my reply to your question in my original thread: here

Well, I had to re-install windows because of a computer problem and lost the UE4 program. I have been trying to install again and got half the program downloaded, I paused it to download the other half today and now the launcher crashes and won’t download the rest. I went through all the trouble shooting I could find for the launcher and it still doesn’t work.

maybe helps or de-install and start all over again.

Just tried that, it got all the way to being able to start the download then crashed again. Seriously, if Epic can’t get the installer bugs worked out they should pull the program or write a simple installer. I’ve wasted enough time with it - I’ll try again after they sort out the installer.