Simple move to location bug after changing versions

Hello and thanks for all who can help me.

I’m developing a board game with tiles that get positioned when you get to their position. The project started in 4.3.3 if i well remember, but i worked on it on 4.4 and 4.5. I decided to include now the UMGs and moved it up to six, where it started crashing when i used UMGs. Ona google search i discovered that its a common problem, solved on 4.7. So i moved it up again, and it messed up my movement structure.
After correcting the public variables, some broken variable and few issues, i got to a part where my character spawns the tile, sets its position, get its position and uses Simple Move To Location, only that this last part is not working. I’ve replaced some nodes, the navcast and navbounds (which is bound to rebuild nav each 0,2s), but still my character is not moving.
My structure is a bit big for a picture, but i’m willing to update it or something.

UE version - 4.7 prev 7 (now), its keeping most of the 4.5 structure that was working fine
Machine - Intel I7 quad 3ghz, Mem 8 gb, Geforce 660ti
Problem - Spawn tile to walk over and then it doesnt walk over. Debuging shows everything fine, but “Simple Move to Location” doesn’t move MyCharacter.

It’s really hard to tell from your limited information. Have you tries using visual log to debug it? Run vislog console command, start recording and investigates whatever the log gathers. There should be plenty of information. And feel free to share the recorded file, we might be able to help.



Sorry for the simplicity of the information, i’m no true programmer.

With the aid of the visual log, i manage to find only one data, which is the problem. According to it, “LogNavigation FPimplRecastNavMesh: InitPathfinding start point not on navmesh”.

I have never set that before, and it worked. How can i do ti?

By the way, i update to prev 8, in order to test it, and i discovered the problem, (i think). For some reason, its not rebuilding the navigation in runtime. I have the RecastNavMesh-Default, that comes with the NavMeshBoundsVolume (this one is covering all the area i’m using and a bit more), and an AbstractNavData-Default, which is for testing, but even without it, it’s not working.
The same config was working on 4.5, and navmesh is working fine in objects that are already on the map when it is loaded, but also doesn’t rebuild in runtime.

So, i Finally worked ou, i think, the problem. In this newer version, the rebuild on runtime has to be activated on the project editor AND the Actor in game, and perhaps also on the AbstractNavData, which seems to be coping the Project Editor settings.
Thanks to Miezko for the help


Just a comment here, AbstractNavData is for navmesh-less pathfinding (like moving in a straight line to the target) so that we have both navigation and navigation-less movement handles in a similar manner.

I solved this warning here AI Navigation fails with navmesh set to Dynamic runtime generation - #12 by 6r0m