Simple? flash problem

So i have been using the MouseInterface gem for a few months now:

And for a few days i have been trying to change the mouse cursor.I have close to zero experience in flash but for the most part i managed to achive it.So the gem comes with a flash file that uses a mouse cursor icon.The only thing i wanted to do is change the icon of the mouse cursor with my own crosshair texture.(128x128).

So what i did in flash is just double click on the cursor_png and and imported/replaced with my own texture and changed its name>than export as a SWF.I placed that file in UDKGame>flash>MouseInterfaceContent

And when i import or reimport it in udk i get this message.

Decided to place the texture of the crosshair in the same folder as the SWF just in case but the result is the same.Tryed naming the texture and SWF with different names but no change.If i play the SWF on a videoplayer i can see that is working and i can move my new cursor so im not sure why isnt udk finding the texture for the SWF file,and if its needed as i suspect that a SWF file shoud contain the texture?

when you changed the name of cursor_png did you remove the file extension and set it to export for actionscript in the library properties?

Thank you .Its as you say but just in case.

I think i fixed it.When i doubled clicked the png texture in flash i went to the action script folder and decided to uncheck ¨¨export for actionScript¨¨ and now i can import the SWF in udk without any warnings and it works.So if i understand this right,the SFW was awlays vinculated to the old name ¨¨cursor¨¨ which was the texture i was replacing and thats why i was getting that error?

Also in my foto of the flash editor>above the red square i made there is a text ¨¨ Vinculacion con AS¨¨.Which i supose it means vinculated to action script,so i double clicked it to disable it when exporting the final SWF.

Something you removed on the way perhaps the code. It shall work, I tried the mouse gem a lot of times.

I used to use the mouse cursor gem, but finally opted to use the hardware mouse cursor, as there is a slight but noticeable lag on the mouse movement. It can actually be quite nasty.

Yes,it looks like i removed something from the scripts and it works.Im using the gfx kismet to toggle between diferent mouse cursor textures for different weapons.

Coldscooter,you experienced lag with the mouse gem?This is really strange as im not experiencing anything.A screen refresh thing or im lucky?Or maybe because im extending from a simple game and a ut player controller?