Simple flag with wind

Hi guys,
I created a simple flag with a pole in MAX, exported it alond with its apex file (nvidia tool). When I import it and hit play, flag does drop a bit as it should. Then I added wind directional source but it does not affect the flag at all. As I see, that wind is made just for cloth so not sure why mine isn’t working. When I go to edit the flag and hit show wind in that window, flag behaves as it should.

I can’t see any way of “attaching” the wind to the flag.

Hi Crayox,

What is your wind strength and speed set to in your Wind Directional Source actor?

This should not require any additional setup when using wind and apex cloth.

If you’re using 4.7 the default values are pretty high at 1.0 for strength and speed, but if you’re using 4.8 the values have been lowered to 0.1 for both.

If that’s the case you may just need to increase the strength a bit until you’re happy with the result.

Let me know.


I’m on 4.8 and I tried strength/speed of 10 000. And I’m pretty sure I set it up right since it works in preview.

Would you mind posting the cloth mesh and the cloth apb file here in a zip file and I can take a look?

Using my test cloth I’m not seeing any issue on my end with 4.8.

Yes, here it is.

Looking at the file in UE4 you need to adjust the max distance that you’re painting for your cloth.

The value that you used 30 is rather low, especially for the end of the flag. Longer distances will be more accurate for realistic cloth rendering.

Here is an example:

The one on the right is your original flag cloth asset.

The one on the left is the same flag cloth asset that I re-did the max distance painting for. I increased the distance to 100. It can probably be a little lower than that and still be as accurate. The problem with 30 as a distance is that this is the amount of distance the cloth can move in any direction. the end portions of the flag tend to look like they’re hanging mid-air because of this. So as you can see in the redone one the cloth is much more accurate.

In this example I also turned down the wind to 0 so that it would fall completely.

This is a gif of the flags with the default wind actor settings: Dropbox - Error

Yer, thanks, it’s much better looking now but it’s still not affected by the wind at all.

Maybe it’s due to bones? I didn’t really gave my flag bones, but only a flag pole object that I added as a bone. But again, it all looks ok in simulator when you edit an object in Unreal, but then in the scene, nothing happens with the wind.

Hey Tim…have you tried my flag in the scene?

Hey Crayox,

The image I have above is showing you’re original flag on the right and one where I imported it into 3Ds Max and adjusted the max distance when painting the weights.

When I test everything on my end I’m not seeing any issues with the asset you’ve provided aside from the painted max distance.

Placing the wind actor and changing it’s direction has worked for me as well. I’m not sure exactly what may be going on.

We now have 4.8 final release that is out. Have you tried in this version?

Also, do you have the Content Examples project from the Learn tab?

If so, we have the cloth test level. If you check the assets in this you can see that Wind Directional Actor will affect them as well. There is a wind directional actor placed in the corner at the first example (1.1). I placed your asset in this test level and everything worked right away for me as well.

Let me know what you find.


Oh! Got it! I went into Content Example and saw how everything works there. Then I deleted that wind and added one myself and everything went dead! Then I figured it out. It was the angle! If it’s perfectly aligned, it doesn’t effect the flag at all.

Hm another thing now. It seams strength and speed does not seam to change the flag behavior at all. I tried 0.1 as well as 100 for both and the flag seams to be the same. Like there’s a mild wind.

Without the right settings wind will not affect your Apex, i use Maya for creating the Apex files and found out myself that the setup is very tight for getting this to work. In the skeletal mesh editor for example you have to add under Clothing the> ‘’.apb’’ file for your FBX, APEX, cloth skeletal mesh. But i understood you allready had this working. I hope you have it working well allready!

Yer, I had a weird thing. My wind was in the exact same angle as the flag so it did not affect it…the flag always worked in the editor/simulator in UE.

That’s working now but the wind strength nor speed seams to have any effect.

There is an Original UE4 demo with many examples of cloth and wind. Mayby those can help you further. It is called the ‘‘Content Example Directory’’ and can be downloaded from under learn in your UE4 launcher.

Yes, I’ve been to that. But like I said, those settings don’t seam to work.

I’ve had the same issue as Crayox. I’m trying to fly a simple flag in my scene with APEX cloth. It blows around just fine, in the specified direction determined by rotating the WindDirectionSource, however, the Strength, Speed and Gust parameters seem to have ZERO effect. I’ve also tried adjusting these parameters in the “cloth” level of the Example Content demo, (even up to values of 9x10^24), and the cloth blows the same as it does at default 0.1.

Actually I’ve recently entered a bug for the speed and strength not having an effect when using positive values. When using negative values this will work fine, but obviously everything is opposite the direction that the arrow indicates for the direction. I reported this with UE-17471. It’s marked right now to be fixed for 4.9, but this could get pushed to a later version depending on other priorities.

To the original issue that Crayox had, I’ve not had any issue getting cloth to work in the scene with a WDS actor facing in any direction.

Thanks very much Tim for the work-around!


Negative wind STRENGTH does have an effect, however, speed and gust parameters still have no effect–whether positive or negative.