Download

/sigh really frustrated / annoyed. moving from 4.7.6 to 4.9.0 killed my project

Hi its really depressing, everything was packaging and running fine in 4.7.6, my DK2 VR headset was working fine with UE4 as it was using the old 0.6.0.1 runtime. Then Oculus updates to 0.7 runtime and 4.7.6 UE4 no longer works.

So I update to 4.9.0 and I cannot get the game to package. I deleted all the Redirect files in the Buildengine.ini file to clear the redirect errors, this I found in another thread. Its saying the file name is too long to save and lots of other errors that have cropped up. Its really ****** me off because I was due to Kickstart my project on Monday, I upload my demo’s and oculus bring out a frigging update and suddenly no one can try my demo.

I worked most of the summer on this by myself and now my holidays are up and back to work full time I just don’t have the energy or time to be messing with it, especially when each backup of 50 gig takes about an hour to copy.

Is there anyone who could take a look and see what the problems are please? I don’t even know where to start its just really depressing.

Its just a blueprint project with nothing special in it as I am trying to build it on my own with not much prior experience inn coding.

Fal

I Falan,
I am very sorry to hear about your trouble. The issue does not ring any bells to me personally but I have passed along a link to somebody in QA to see if they have any ideas.

Feel free to PM me if you are not able to get any traction. Issues like this are very serious to us.

It may help to post any log lines here, including the lines saying filename too long etc.

RyanB thanks for that, it is frustrating you know I just worked so long on it planning on releasing it at the end of summer then this happens. What kind of logs do I include and where can they be found please?

One way is to go window->developer tools->output log and copy all of it there, or you can find your project folder on your hard drive and goto the ‘saved’ folder and there should be a logs folder in there. Then just find the most recent log and try to find an error that mentions one of your assets.

RyanB ok thank you I have uploaded the latest log, it shows the various fails I think.

I am just unsure where to start on them or what they tell me. I don’t understand why they packaged before and not now you know.

Think I’ve found the problem, it looks like a lot of your filenames are too long, but then again these looks like KiteDemo assets so perhaps that’s not the issue. Still sifting through, that’s a heck of a build log!


[2015.09.03-18.46.17:905][732]PackagingResults:Error: Error Error Couldn't save package, filename is too long: E:/Thurs_3rd_church_backup/Church Project/August backup/backup/Church_real - Copy/Saved/Cooked/WindowsNoEditor/Church_real1/Content/KiteDemo/Environments/Foliage/Flowers/Heather/M_HeatherPatches_Inst2_BrownPinkVairience_NoWind.uasset
[2015.09.03-18.46.17:916][733]MainFrameActions: Packaging (Windows (32-bit)): UE4Editor-Cmd: [2015.09.03-18.46.17:902]  0]LogInit:Display: LogCook:Error: Couldn't save package, filename is too long :E:/Thurs_3rd_church_backup/Church Project/August backup/backup/Church_real - Copy/Saved/Cooked/WindowsNoEditor/Church_real1/Content/KiteDemo/Environments/Foliage/Flowers/Heather/M_HeatherPatches_Inst2_BrownPinkVairience_NoWind.uasset


Also, I find it weird that the cooker logs Package Saving as a Warning… is that intentional?

I’ve also found a few Lightmap errors which you may need to look into as well, starts around line 10,800



[2015.09.03-18.37.14:451][771]MapCheck:Error: Error candle_holder_10 Component is a static type but has invalid lightmap settings!  Indirect lighting will be black.  Common causes are lightmap resolution of 0, LightmapCoordinateIndex out of bounds. 
[2015.09.03-18.37.14:451][771]MapCheck:Warning: Warning candle_holder_10 Static mesh actor has NULL StaticMesh property 
[2015.09.03-18.37.14:451][771]MapCheck:Warning: Warning candle_holder_10 Static mesh actor has NULL StaticMesh property 


Also, I’d recommend possibly deleting all your temporary folders for the Project. Delete the Saved, Intermediate, Build, Binaries folders and maybe even try deleting the DerivedDataCache. The cooker might still be referencing old assets.

EDIT: Also, gonna move this to the ‘Feedback’ section since it’s probably more relevant there…

@TheJamsh Hi and thanks for taking a look at this mess too :slight_smile: I really appreciate any help I get as I know you guys must be very busy.

I deleted those folders as you recommended and it actually speeded everything up as far as building the lighting went. I have these errors in the map build after:

Would you be able to point me in the right direction for fixing these please?

EDIT- f**king hell it just packaged after deleting those folders you said! That is bloody amazing thanks so much. It is easy to forget when using software like this just how completely clueless I am with it when it goes wrong I really appreciate the professional eye you can offer looking over this. I would still like to clean the project errors up one at a time if you would have time to maybe look into that image above and perhaps provide some basic steps.

Thanks again I am off to try it with the latest 0.7 runtime from Oculus :slight_smile:

Glad you found it works. I just saw the other day in the 4.9.0 Released thread that after updating the engine one should ~always~ delete those folders. I’m still new and that was a very essential tip.

Hi mate I found them in my project folder, which is where you store in, for me its E: drive, you need to be able to find this folder before you can start. Then once you open it you have these folders, Build, Config, Content, DerivedDataCache, Intermediate, Saved.

I opened up the Build, Intermediate and Saved folders and deleted the contents inside. I did not delete the actual folders although this might not be a bad thing to do, I just removed the internal files and folders. Then I launched the game.

Those folder contents were stupidly huge like over 20GB I think for me or somewhere that close. The Lighting Build time was cut in half roughly in the Editor although I don’t know if that was supposed to happen. It was a nice side-effect.

Ahh glad it worked! Occasionally it does just help to clean up the folders, some of the config files / temporary files don’t transfer well between engine versions.

Those yellow errors indicate that you have a static mesh actor in the world but without any actual mesh assigned I believe, you’d have to go through the scene using the Scene Outliner and delete the ones you find. However if you click on the text, it should take you directly to them and you can hit the delete key or fix the issue.

That might in turn fix the red warning as well.