Download

ShowOnlyActors in SceneCaptureComponent is no longer Blueprint Writeable in 4.20. How to set?

This breaks my existing BP that worked in 4.19. How else can I set the ShowOnlyActors variable from a Blueprint?

I reckon you are referring to the imposter rendering solution from Fortnite. Basically, if you are using the UE 4 downloaded from the Epic Game Launcher, I can only sorrily tell you that there is no freaking way to make it work. However, if you built your engine from the source code from GitHub, you can delve into SceneCaptureComponent.h and find the definition of TArray<AActor*> ShowOnlyActors; Above this line you can see an option named “BlueprintReadOnly”, and you can change this into “BlueprintReadWrite”, and finally re-compile the engine and you will see it working.