Download

Showdown demo has camera uncontrollable and half-way inside ground?

I’m just checking Unreal Editor as an alternative to Unity for a new project due to some issues I’ve found with Unity5. I’ve taken the “FeaturesTour2014”, and that seemed great. Now I downloaded the Showdown demo, but that seems to have a couple of weird issues:

1.The camera seems to be half-way inside the ground so that half of what is shown is almost just white fog (see screenshot).
2. It says shift+f1 for mouse control, but it doesn’t really give control even if I press that. Only way to gain control is to go to editor controls using “eject”.

showdown.JPG

Other than that the showdown demo of course looks great, so why these seemingly primitive flaws? What am I not getting?

  1. When you start with the fresh scene (downloaded from Unreal Marketplace) and click the Play button do you see the correct scene? There might be a setting related to VR and non-VR playback… I can’t remember what it could be, the last time I tried Showdown was a few months back.

  2. Showdown has a lot of Blueprint and Matinee-scripted changes to the camera, etc. and is targeted for VR… so the usual Shift-F1 etc. doesn’t work as per usual.

  3. What version of UE4 are you using?

I would suggest start with the smaller demo scenes to check out UE4 eg. “Blueprints”, “Sun Temple”, “Lightroom” and “Berlin Flat”. Other demos like Showdown and Inflitrator have lots of camera scripting and other things going on so unless you are in Editor mode you won’t be able to easily “walk around” with mouse control, etc. They can be overwhelming to analyse as well for anyone totally new to UE4. I’m not an expert but it took a while to piece apart the Showdown and Infiltrator demos, change materials, re-lightmap, etc.

Well, in edit mode it doesn’t start from the place the camera starts - it’s looking from above and from the left. So sure, the scene is there as it is after pressing play, it’s just that after pressing play the view is half-way inside the ground.

Okay, I didn’t know this was more for the VR. The reason I actually wanted to check this demo was to just see that I’d have no rendering issues with Unreal Engine as currently I’m having some weird issues with Unity after moving from Unity 4 to Unity 5(.3).

It’s 4.10.1.

Thanks for the suggestion and your other tips too!

The thing is, it seems to me that Unreal actually doesn’t really fill the needs of the project I’m starting that well, as I would need an equivalent of the culling mask property Unity has in its Camera component. Unreal Engine doesn’t have that, and it seems to me that there isn’t much of a workaround for that either, unfortunately. Due to this I don’t (currently) have the motivation to dig deeper into the engine - unless someone proves my impression wrong of course, by showing a way to (easily) do culling with the camera.

I am getting the same issue with 4.10.1 and 4.9.2 in VR on my Oculus rift DK2

I had this demo working before but the startup was different? Previously it had a logo that had sparks spraying from it. Now it just has a spinning logo.

Was the demo changed?

Head tracking still works but it is almost like the camera is at the same level as the floor instead of being at “eye” level.

To even look at the starting logo you have to be looking upwards in the headset at 45 degree angle. Like your looking at the sky instead of straight forward.

Showdown looking up.jpg

Same issues here.

It seems the Character has a few detached wires?! I’m guessing it’s because Unreal complained that the versions didn’t match, but I skipped conversion anyway, because I’m lazy.
So basically connect the wires back up! I also got rid of the negative sign in the 160 height box, because it put me twice as far out :slight_smile:
Capture.PNG
3548f6b69aa466aac35918758142465265eedbfa.png

Can verify the above fixes make the demo work properly for me :slight_smile:

Has the intro always been black? Was it like this in a previous version?
https://www.youtube.com/watch?v=SedjQvb0CII

This fix adding a scene component to the player bp worked for me. Then just raise the scene component and the camera will go higher.

Well done!
The fixes work great for Version 4.9.
In version 4.14 you need the fixes and to change Tracking Origin from “Standing” to “Eye Level” in the drop down