"Show All Files" option in VS does not work

Hi. I’m trying to import some code from an older version. Normally, I copy all files to the project directory, use the “Show All files” to view all the files with their folder structure intact and then I add them to the project.

However, with unreal projects, this option just doesn’t work. Im pretty sure it only happen with projects generated via the “generate project files option”.

Hey letters-

Where are you referring to when you use “Show All files”? Is this inside visual Studio, the editor, or are you referring to the explorer window? If you are manually adding code to a project outside of the editor’s “New C++ Class” options (adding class through VS or copying from one project to another) then you’ll need to right click on the .uproject for the project where the code is being added and select “Generate Visual Studio Project files” as you mentioned. This will update the source code and allow the newly added code to be recognized by the project.

Cheers

Doug Wilson