Download

Show 3D Widget not working?

Hey Everyone,

When I tick the “Show 3D Widget” on a vector component in the blueprint menu for my sprite, the 3D Widget doesn’t appear on my character (or in the blueprint viewport, but I’m not sure if it’s supposed to). My guess is that it’s invisible for some reason.

Any ideas?

Show3DWidget.jpg

I realize a picture would probably help. So if you look at the above, you can see that the box is ticked. The same blueprint is associated with the lift sprite that’s placed within the level.

I’ve tried working through this about five different times. I’ve tried using an older version of Unreal. I’ve tried switching between toggling between local and world. I’ve tried disconnecting some wires. I’m not sure what the deal is.

I should also note, this is a video tutorial I’ve been following https://www.youtube.com/watch?v=vwZVlgcMGI4&index=9&list=PLZlv_N0_O1gauJh60307mE_67jqK42twB&nohtml5=False.

This is somewhat on the same topic (I hope this is not seen as spamming the page). My custom categories don’t show up in the main viewport window (see the pictures above); they only show up in the blueprint window. I bring this up because I’m wondering if I’m doing something wrong, if something is messed up with my version of Unreal, or if’s a combination of changes through updated versions of Unreal and certain features being changed or obsolete.

Okay, interesting. After playing around with it some more I figured out you can’t use a sprite with a 3D Widget. I created a cube and it worked perfectly. But what if I want to be able to use a 3D Widget with my sprite? I wonder if it would be a good idea to parent a sprite to a cube and make the cube invisible or something along those lines.

Why make it 3d at all if you use a sprite?

Honest question.

To answer your question, I was following a tutorial by Zak Parrish where he’s creating a lift/elevator system using blueprints. I’ve just gotten back into Unreal, and I liked what he was able to do using the widget to manipulate where the platform would go to.

That said, I did manage to get it working. I’m not really sure what the problem was. But I did run into some bug (at least it looks like a bug to me) where when I move the endpoint below the platform (as opposed to the default location, above) the lift will ignore collision with the player and go right through him, causing him to get stuck. I’ll have to figure out what the deal is with that later.

Anyway, if you have a better idea for being able to create a similar system, I’d like to know. I’ve been messing around with Unreal hardcore whenever I’ve had the chance (spent like 12 hours working on stuff yesterday).