ShooterGame - CustomShooterGameModeBP crashes inside the BP editor

After some time working on my game using the ShooterGame framework, I came to this issue that is actually blocking me to finish some core features.

I’ve created a custom class, in c++, inherited from ShooterGameMode and created a Blueprint Class from that.
Whenever I try to open this Blueprint class inside the editor, it loads 100% and crashes the editor, instantly, without leaving a crash report.

After facing this problem, I created another blueprint class, this time inherited from the ShooterGameMode class. Same results, when I open it and load, the editor closes.

So… I have created a clean shootergame project and gave it a try, and it worked fine. The problem is inside my current project.

BUT

The ShooterGameMode class was untouched so far, and I’m facing this crash in an unchanged class, only in my project!

Is it something I should look at the config files? Any ideas of what should be the crash cause here?

Would You mind to attach a crash report?

Sorry for the delay.

The editor just closes, not displaying any crash report. I’m still having this issue, even recompiling the entire project on a different PC.

Thanks for the reply, again.

My last crash simulation opened the crash report window, thus I could gather the info needed:

AppCrash:
link text -

Editor Log:
link text

Looks like Thread tried to access protected memory. But I see no major issues except:

LogUObjectGlobals:Warning: Failed to find object 'Class None.'

and

LogCrashTracker: Crashtracker disabled due to settings.

Try to enable it by typing crashreports in console.

Also move the topic into Bug Reports category, so Epic Staff could help You.

Hey Gbr-

I tried testing your issue and was not able to reproduce this in a new project either. For another test, can you try making a copy of your project and convert it to 4.14 and let me know if the crash still occurs there as well? Additionally, can you run the project in Visual Studio debug mode and cause the crash? This should force the project to kick back to Visual Studio and display the crash callstack. Please copy/paste the callstack here for additional information.

S-ed, thank you for your promptitude.

I believe I need Epic’s support as you said.
Anyway, trying to enable crashreports does not seem to change the fail Log I came up facing and nor showing more relevant messages. Gotta try the Doug Wilson suggestions.

Hi, Doug.

I could not run the project inside 4.14, came through a new issue detailed in [this post][1].

I need your guidance inside the Visual Studio for this attempt you suggested. I’m still under 4.13’s project. Here’s the break point:

Didnt find any useful information after this, where should I go from here?

Yeah it’s fine. Sorry this is gone beyond my level of awesomeness.

Good luck with it, hope You’ll find a solution soon.

Based on the screenshot it only shows an error with the editor directly. In the Epic Games Launcher, please try clicking the dropdown arrow for your engine version (4.13.2) and select the Verify option to ensure all engine files are built correctly. If you still get a crash when opening your blueprint, please send a copy of your project so that I can view the crash locally.

Hi Doug,

I’ve done everything you asked me to do.

After downloading the Editor Debug symbols (This last weekend I’ve formatted my PC and forgot to download the symbols), I came to these new messages (too long to post in this reply: https://codepaste.net/2eqyic)

Maybe it can be useful.

About the 4.14 update: after updating to 4.14.3 and simulated the crash, it still occurs. Crash log also indicates the same function (GameMode::StartMatch()).

Please tell me if you’re still gonna need my project.

Thanks for your attention.

Hey Gbr-

I apologize for the delayed response. I have not been able to reproduce your crash locally yet. It may help me understand the cause by seeing the issue on my end, if it’s still possible for you to provide a copy of your project.

Surely, here it goes:
https://drive.google.com/file/d/0B389WdSTmsVRbE9qRld4MDZEYzA/view?usp=sharing

Looking forward for your response.

Hey Gbr-

Thank you for the project. I was able to follow the stack trace from the crash to where StartMatch(); had been added in AShooterGameMode::PreInitializeComponents();. When this call is made, it is then crashing on if (GameSession->HandleStartMatchRequest()) because GameSession at this point (opening the blueprint) is null. Commenting out the call to StartMatch prevents the crash from occurring. Depending on the reason this call is being made, you may need to make the call elsewhere, or at the very least check if(GameSession) prior to calling StartMatch();

Cheers

Doug Wilson

It worked! Thanks, Doug.