ShooterGame Couldn't find target rules file for target


I don’t know what’s going on lately, but all of a sudden after the update to the launcher, things just seem to be incredibly broken.

When I create a blank ShooterGame template with ShooterGame as the defaulting name, I have no issues compiling code. However when I choose to create a ShooterGame template and have a custom name, this happens.

Info ERROR: Couldn’t find target rules file for target ‘MyNameGame’ in rules assembly ‘MyNameGame_EditorRecompileModuleRules, Version=, Culture=neutral, PublicKeyToken=null’.

G:\Unreal4 - This is my custom built unreal 4 folder.
G:\MyNameGame\MyNameGame.uproject - self explanatory where my project is.

Any ideas?

I’m currently having the same problem. I generated a project from ShooterGame using the Unreal Engine frontend. When using the name “ShooterGame” to generate the project all is fine. When using a custom name I get the above “Target rules” error.

I believe the problem could be that the build target files inside the project are still called ShooterGame* - ShooterGame.Target.cs, ShooterGameEditor.Target.cs, ShooterGameServer.cs etc. The project generator should probably generate these files to match the project name given by the user.

I verified this was the case by renaming ShooterGame.Target.cs to [MyGame].Target.cs, and renamed the ShootGameTarget class inside the file to be [MyGame]Target, and did this for the other target files, and then the build got passed this error.

So it seems generating a ShooterGame project with a different name isn’t working right.

P.S This is with a github build of the 4.4.3 engine.

Hey Satori-

I just wanted to confirm that we are seeing the same thing. When you create a new ShooterGame project and rename it the first thing you do is compile in editor and get this error, is that correct?

That is what I’m seeing with the same setup as OP.

Hey Mrb83 and Satori-

This has been addressed (CL 2319926) and will be included in a future release of the engine.


Is there anything we can do to fix it now or just wait for the update?

Waiting for the update would be your best option at the moment.


I have just come across this error on 4.5.1. Is it still an ongoing issue or has it now been fixed ?



I was able to create a new ShooterGameTemplate with a different name from the launcher. Are you working form the launcher or from GitHub? Also, what is the message you receive when you try to create a project?

Just wanted to say that this same issue is still occurring. I created a new project in 4.6.1 from the launcher, called it something else, got the same issue as the OP.

Hey -

Since you opened your own post regarding this issue here: Shootergame rename from launcher still doesn't work - Platform & Builds - Epic Developer Community Forums I will respond there with information.

This is still broken in 4.7.2.

This is still broken in 4.10.0
So after a full year not fixed.
I came here because i encountered this first with the sidescroller c++ template and checked then also the shooter template too … its the same bug.
And as for the cl number its of no use when its nowhere to be found on the net except for this thread.

With further investigation i was on the wrong track …
this issue seems to be fixed because the files are indeed named right.

i have the following problem:

so that is definetly still an issue and due to the similarity of the error mesage one can end up here with google

Hi Smash,

I took a look at the other issue that you linked, but was unable to reproduce that issue in 4.10. If you have not already done so, could you create a new post in the Bug Reports section about the issue you are currently experiencing with as much information as possible and we will take a look at what is going on.


I know this thread is pretty old, but I hope I can help. I had the very same error popping out, but as I tracked down I found out that error was coming because of in correct sign automatically generated by Win10 in project folder name (yeah its really weird). In Intermediate folder there is a “PCH.ProjectName.h.cpp” file. There should be a path to your project’s header file. Check if the path is correct. I had some incorrect signs there and after manually changing them, error disappeared. Peace