ShooterGame 4.10.1 No Sound for Footsteps

Fresh copy of the ShooterGame in Engine 4.10.1.

I know the ShooterGame has sound notifications for the walking/running animations and it works locally. What is boggling my mind is why it isn’t working for other players connected to the same network.

As I understand it the sound isn’t called through the network, it is simply done through the animations notifications. So if it works for the players local pawn, it should work for all other instances of the same pawn as well. I know it was working back in 4.8 but now in 4.10.1 it isn’t working. I don’t know if its a bug (if so I can’t find any mentions of it), if I am missing some new API change in 4.10.1, or what ?

Every time I delete and reinstall its the same result.

Hi Nonlin,

I tested this by Playing In Editor (New Editor Window) 2 Player. All sounds were present in both windows, including footsteps.

Are you testing with the UE4.10 version in UE4.10 or are you opening a previous version of the Shooter Game in 4.10? Let me know of any other differences you can think of to reproduce this on our end.

Also, please send a copy of your dxdiag.


I had originally ported my code from 4.8.2 to 4.10.1 manually and then tested a fresh copy of the 4.10.1 shooter game to confirm my results.

Just to confirm, you are saying you do in fact hear the footsteps of non-local players on each game instance for a fresh instance of 4.10.1 of shooter game?

Here is my DXDiag

To confirm, non-local players can hear their own footsteps and all sound effects tested with the Shooter Game (fresh) packaged from UE4.10.1. This was tested in two ways:

  1. Opening two different player windows on the same machine
  2. Hosting a game over the LAN, playing on a “host machine” vs a non-local player

In both tests, all sounds were functioning. Players could hear their own footsteps, gunfire, fire from other players, etc.

Also, in case it wasn’t clear, I need the dxdiag from a machine where sound is not functioning and across how many machines are you testing, if more than one? In other words, the host + how many additional non-local machines are being tested at one time in one instance of the game?

This was done all on the same machine. The issue isn’t with players not hearing their own footsteps or gun fire and the issue isn’t with not hearing fire from other players, the issue is not hearing footsteps from other players.

That is the Dxdiag from the machine where you cannot hear other players footsteps.

To test I ran two instances on the same machine (also tried packaging and running two instances on the same machine via executable). On one instance I push the forward key to have the player move and then quickly alt-tab to leave the player in a constant state of motion. Then I move to the next instance and go to the player that is moving to see the animation of the player working but not hear any sound emitting from the players footsteps. I can do the same test for shooting by holding down fire and quickly alt tabbing to the next instance. I can hear the other player shooting on the second instance.

I’m gonna make a video when I get the chance to show you what I mean. It will be of a fresh project of the shooter game in 4.10.1

Hi Nonlin,

No need to make a video… After you clarified you could not hear the opponents footsteps I was able to reproduce this with the 4.10 version of Shooter Game and have entered the following bug report: JIRA [UE-24842]. When this issue is addressed you will be notified with an update to this post.

Thanks for bringing this to our attention,


Well thanks! Now I can have some peace of mind. I’m really curious as to how this managed to stop working as it seems it would be engine side rather than having anything to do with their code directly. Please if possible give details of the fix. Thanks again!

When developers went to work on this they could not reproduce in the latest version of the Engine, but no specific work has been documented, hence I cannot give details of the fix. Let us know if you are still experiencing this.

Yea I’ve recently moved on to 4.12 and the issue is no longer there.

Thanks for the reply.