ShooterExplosionEffect.cpp, Super::Tick Calls Destroy Immediatelly

ShooterGames’ ExplosionActors do not display their Explosion Lights in game, nor do they appear in the Scene Outliner when created.

I have traced the bug back to calling Super::Tick inside it’s tick function, which immediately destroys the actor but because the actor still runs it’s ‘BeginPlay’ function the effects and sounds are still spawned and it appears to function correctly.

Removing Super::Tick causes the actor to display it’s ExplosionLight properly, and destroys itself when the light fades out.

This can be easily seen by setting the ‘ExplosionLightFadeOut’ in the actor to something like 5 seconds, and you will see that the Actor immediatelly destroys itself regardless. Removing Super::Tick prevents this from happening.

Hi ,

Sorry for the delay in responding to your post. What version of the Engine were you using when you noticed this? I tried reproducing this issue in 4.6.1, but could not see the results that you described. The explosion effect and light were always being destroyed by the ShooterExplosionEffect’s Tick, and not the Super’s Tick.

Interesting… I’ll do a little more digging and get back to you , I was on 4.6.1 at the time.

Do you still get a bright yellow flash with the explosive weapon even with Super::Tick inside the Tick function? Also what happens if you set the timer for the explosion light to something like 10 seconds?

Mine disappears instantly regardless of the life of the light. I’ll try and get a video/pictures up tomorrow!

I had increased the ExplosionLightFadeOut time to 5 seconds, then added a break point at the Destroy() line in ShooterExplosionEffect.cpp, as well as in Actor.cpp (the parent class). When I ran the project through Visual Studio, the only break point that was triggered was the one inside ShooterExplosionEffect.cpp, and it happened after 5 seconds. I did notice the yellow light, and in the Scene Outliner the only time the term “explosion” appears is during the 5 seconds between creation and destruction of the effect.

What are you using to trigger the explosion effect? I was using the default grenade launcher.

Yeah same test case as yourself… I’ll download the 4.7 version and see if it still occurs for me. Bit of a weird one this!

Hi ,

We have not heard back from you for a while. Do you still need help with this issue? I will be marking this issue as resolved for tracking purposes, but please feel free to re-open this post at any time if you need any additional help.