Shipping failed

Hi there, I have a problem with game shipping. Everything works just fine but this. I have VS13 and VS15 installed and Unreal Engine 4.8.3.

I’ve tried verifying the engine already.

Here is the console log:

Here is the error:

Program.Main: ERROR: Exception in AutomationTool: You are attempting to compile on a machine that does not have a supported compiler!


Do you have 2013 Express or Community installed? Here is some documentation regarding [Visual Studio Setup][1].

Let us know if you have any further questions, thanks! :slight_smile:

Setting Up Visual Studio Development Environment for C++ Projects in Unreal Engine | Unreal Engine 5.1 Documentation

Hey, I have 2013 Community installed.


Do you have any anti-virus up that would possibly block the building process? I’d suggest turning off your anti-virus just to test and see if that helps relieve the issue that you’re experiencing. I’d also suggest verifying your version of the engine, that has helped others in the past. Last but not least, since you installed VS 2013 Community, have you restarted your system?

Looking forward to hearing back from you, thanks!

Well, I tried everything already.
Also, I have a special character in my username. I use Windows 10. Could be possibly the problem with my username?

Please try taking the special character out of your username and see whether or not that works. Sometimes special characters cause trouble with packaging.

Let me know how it goes, thanks!

Is there any safe way of changing my special character in username from MS account without breaking my system?

I’d consider looking on or contacting Microsoft. I cannot tell you the steps to change your username since that’s not related to Epic Games. I just know that special characters can cause issues with Epic Games at times, and it seems that may be part of the issue. I’ve changed my username in the past and have not had any complications however, I don’t know your set up.

Let me know once you’ve done that so we can continue to investigate the issue with the Engine.


Thank you, changing username was a bit messy but it did the magic. Everything works fine now, even some other applications that had the same problem.

Awesome, I’m glad to hear that changing your username on Windows fixed the issue. Please let us know if you have any further questions.

Enjoy your week!