Shiping through frontend didn't work

Hi UE4 Team!

I’m trying to build my project through frontend in Shiping build configuration, but catching errors. Build log in projectlauncher.txt

As I can see he’s trying to build a 64-bit architecture binary (is there some option to configurate building platform through frontend?).

I should admit: when I’m trying to build project in shiping configuration through Editor I’ve got only a 32-bit architecture available (64-bit is grayed and disabled). I’ve got windows 7 x64. DxDiag file in attachment. As far as I know there was a bug which was registered and solved in times of 4.4 version and developer said that in 4.5 it would be fine.

The projectlauncher.txt is saying that the project failed to compile.
I think we will need the UnrealBuildTool.txt log file to gain more data about the problem.

Well, actually everything was in projectlauncher.txt file.
link text

Are there some news?

If you’re building a shipping game you will want to use win32 not win64.

With the binary release we don’t ship the binaries for win64 shipping.
You could build this from source if Win64 is necessary, if so let us know why as that would be important information for use to consider when considering what to include and not to include in binary builds.

Could you describe how you are triggering this build?
I’d like to ensure that we hide the options that don’t make sense when using a binary build.

Thank you,
Chris

Hi, Chriss.

Thank you for the answer.

Let’s first of all solve problem: why I can’t build 32-bit architecture through Shiping configuration with frontend? There is no such option. It builds for 64-bit architecture and there is nothing I can change.

This is an unfortunate limitation in UFE we will need to address.

Would using the editor → File → Package menu to build 32-Bit windows be a viable work around. You can switch to Shipping int the packaging menu.

I can’t build through way which you have described because of Cooking levels - Platform & Builds - Unreal Engine Forums

I’ve replied to that post, i’ll duplicate the information here:

Packaging will build All Maps. However you can specify what set of maps is considered “All Maps” very handy to not include test maps or old maps.

Check in DefaultEditor.ini you might have something like this:

 [AllMaps]
 +Map=/Game/Maps/BSP.umap
 +Map=/Game/Maps/Blueprints.umap

Which could be causing the undesirable set of maps to be built.

Thank you for the answer, Chris. Let’s talk about it in topic which was created early.