Shift + F1 should regain mouse control

In Play Mode Shift + F1 should regain mouse control. That doesn’t work on my Mac.
Where can I overwrite this setting to a different key combination?

Hi rotwang,

I was unable to reproduce this in UE4.12. following these steps:

  • Playing in Selected Viewport
  • In Yosemite
  • Macbook Pro (Retina, 15inch, Late 2013)
  • Selected Shift + F3
  • Result: Regains Mouse Control

Please check these steps and let me know what, if anything, you are doing differently.



Hi ,

when I click play, a message in the topleft corner says “Shift+F1 for Mouse Cursor” and then fades out.
I tried Shift+F1 as well as Shift+F3, but only get the standard apple functions.


Are those keys user-assignable? Can’t find settings for this.


Hi ,

I’ve tested this on another Machine now, running with a mouse plugged in and unplugged using the finger pad without results. Make sure you do not have Shift + F1 assigned as a hotkey in Editor Preferences>General>Keyboard Shortcuts.


HI ,
then its just my computer, I have no hotkeys assigned, using the default preferences.
I need to change the assignment to regain mouse control.
Can’t find settings for this.


I have entered a request to have this tested on an iMac. A couple of more questions to help isolate the issue:

  1. Did this occur in previous versions of the Engine?
  2. Are you using an atypical or special mouse (ie. Magic Mouse)?

I tested this with the Basic demo on 4.10. Behaves the same. Im using std apple keyboard and a std non-apple mouse.

To be clear, the expected behaviour should be:

  1. Clicking Play ->change to
    hidden-cursor mode, mouse move
    controls the camera.
  2. “Shift+F1 for Mouse Cursor” should gain control back to the editors GUI, my desktop and other applications.

I recommend, that any mouse click outside the game window or at least outside the application window (when not playing fullscreen ), regains control.

Your last question apparently didn’t post so I’m quoting it here: “Because it’s still not working for me, I’d like to ask again: Where can I overwrite the “regain mouse” setting? I want to associate it with a different key combination. Thank you.”

If possible, you would set this under Editor Settings>Hot Keys, however, this is not a function you can assign a Hot Key to, as it is default behavior that is not intended to be modified.

I’ve run a test where I assigned Shift + F1 to replace F2 as the Hot Key combo to rename an asset. While successful, this did not interfere with the ability to press Shift + F1 to regain control of the mouse while in Play mode.

At this point, I’d suggest testing both your Shift key and F1 key to make sure that they are functional. Beyond that, we cannot fix an issue that we cannot reproduce in house and, at this point, I have tested this on multiple machines. Moreover, to my knowledge this is the only report of this behavior.

Lastly, the “non-apple” mouse may be the issue. Try unplugging the mouse, restarting your Mac, and retest this using the finger pad in lieu of a physical mouse to see if you can get the intended behavior.

OK so far, I appreciate your suggestions, thank you for your time (a different mouse did not change the behaviour, I might try a different keyboard)

In Play Mode, my shift+F1 has stopped working. It now sets the viewmode to Wireframe. I tried a different keyboard, same thing. Mouse X/Y stopped working. 4.12.5. Been using Unreal since March, first time this has happened.

Deleted .vs, Binaries, Intermediate, Saved directories. Still does not work.

I verified shift keys work in other programs. Tried deleting and readding the nodes.

Mouse works fine in Editor

Windows 10. C++ project.

I went back to a previous checkin in my source code to move forward.

aaaaannnnnndddd…found the problem… Short answer: I unchecked the “Start with Tick Enabled” on my BluePrint that is based on my C++ Player Controller class (which inherits from APlayerController). Once I rechecked it, my mouse, shift+F1 works normally.

I have the same issue on a laptop. I need to hold the fn key to use function keys, but then shift F1 sets wireframe rendering.

Is this a command that can be set to a different hotkey ?

Do you want show your mouse cursor in play game mode? In my case, Shift + F1 + fn work on Mac book pro.

This worked for me:


Then I clicked on the highlighted ‘Keyboard’ up there, and it brought me here:

Then I ticked on the last choice:


Hope this helps!

I had same problem and if these above answers don’t work do this , Zero the player transformations and it will work . this worked for me

I had same problem and if these above answers don’t work do this , Zero the player transformations and it will work . this worked for me

I had same problem and if these above answers don’t work do this , Zero the player transformations and it will work . this worked for me

Shift + F1 does NOT work to regain mouse control when in Mobile PIE session, only regular SM5 Play in Editor session. Windows 8.1, Unreal 4.26.2.